summaryrefslogtreecommitdiff
path: root/app/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-19 19:56:15 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-19 19:56:15 +0100
commit1542c122b3672fe83e027411ad2445772e2d0ed3 (patch)
treee535bc621bd7ffa9d5ce89e0d495df5d1c4ab6fd /app/tools/CMakeLists.txt
parent773810e6583142d7d15263e6481c42aebed6d7f1 (diff)
parentd1a8285f818eb7e5c3d6a05709ea21a808490b8c (diff)
Update upstream source from tag 'upstream/5.1.0'
Update to upstream version '5.1.0' with Debian dir 93ca74b8b4602fce4c9c7740e0cfdde25f086673
Diffstat (limited to 'app/tools/CMakeLists.txt')
-rw-r--r--app/tools/CMakeLists.txt19
1 files changed, 8 insertions, 11 deletions
diff --git a/app/tools/CMakeLists.txt b/app/tools/CMakeLists.txt
index e6716f0..befe170 100644
--- a/app/tools/CMakeLists.txt
+++ b/app/tools/CMakeLists.txt
@@ -1,18 +1,15 @@
-ADD_EXECUTABLE(addcrlf addcrlf.c)
-ADD_EXECUTABLE(bin2c bin2c.c)
+set ( sources listxtp.c )
-SET ( SOURCES listxtp.c )
-
-IF (WIN32)
- SET ( SOURCES
- ${SOURCES}
+if (WIN32)
+ set ( sources
+ ${sources}
dirent.c)
- INCLUDE_DIRECTORIES( BEFORE ${CMAKE_CURRENT_SOURCE_DIR})
-ENDIF (WIN32)
+ include_directories( before ${CMAKE_CURRENT_SOURCE_DIR})
+endif ()
-ADD_EXECUTABLE( listxtp ${SOURCES})
+add_executable( listxtp ${sources})
-ADD_SUBDIRECTORY(halibut)
+add_subdirectory(halibut)