summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-29 05:25:29 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-29 05:25:29 +0100
commit3de481b0038754a68534bb30511b17d638f504ef (patch)
tree316ec3fbe7d311a0fb60f85f4b61cbbf76bd57d5 /debian
parentdb0fcf9142f9ee7035370f832036c873d4c87168 (diff)
New upstream release
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/0100-gtk.patch62
-rw-r--r--debian/patches/0700-info_file.patch18
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules4
5 files changed, 88 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index ac801a4..ce47f1e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,10 @@
-xtrkcad (1:4.2.2-2) UNRELEASED; urgency=medium
+xtrkcad (1:4.2.4a-1) UNRELEASED; urgency=medium
* New Maintainer (Closes: #849139):
- debian/control: Add myself as maintainer.
- debian/copyright: Add myself to debian/*.
+ * New upstream release (Closes: #847843, #784423).
+ - New debian/patches/0100-gtk.patch to prevend gcc format-security errors.
* Remove debian/source/options.
* Remove debian/source.lintian-overrides.
* Change debian/compat to 10 (no changes required).
@@ -13,6 +15,8 @@ xtrkcad (1:4.2.2-2) UNRELEASED; urgency=medium
- Change Priority from extra to optional.
* debian/rules:
- Enable hardening.
+ * New debian/patches/0700-info_file.patch to add requested directory entry
+ and INFO-DIR-SECTION line.
-- Jörg Frings-Fürst <debian@jff-webhosting.net> Wed, 28 Dec 2016 17:27:47 +0100
diff --git a/debian/patches/0100-gtk.patch b/debian/patches/0100-gtk.patch
new file mode 100644
index 0000000..798eed1
--- /dev/null
+++ b/debian/patches/0100-gtk.patch
@@ -0,0 +1,62 @@
+Index: trunk/app/wlib/gtklib/gtktext.c
+===================================================================
+--- trunk.orig/app/wlib/gtklib/gtktext.c
++++ trunk/app/wlib/gtklib/gtktext.c
+@@ -448,7 +448,7 @@ EXPORT wBool_t wTextPrint(
+ dialog = gtk_message_dialog_new (GTK_WINDOW (gtkMainW->gtkwin),
+ GTK_DIALOG_DESTROY_WITH_PARENT,
+ GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE,
+- error->message);
++ "%s", error->message);
+
+ g_error_free (error);
+ gtk_dialog_run (GTK_DIALOG (dialog));
+Index: trunk/app/wlib/gtklib/print.c
+===================================================================
+--- trunk.orig/app/wlib/gtklib/print.c
++++ trunk/app/wlib/gtklib/print.c
+@@ -120,7 +120,7 @@ WlibApplySettings( GtkPrintOperation *op
+ dialog = gtk_message_dialog_new (GTK_WINDOW (gtkMainW->gtkwin),
+ GTK_DIALOG_DESTROY_WITH_PARENT,
+ GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE,
+- err->message);
++ "%s", err->message);
+ gtk_dialog_run (GTK_DIALOG (dialog));
+ gtk_widget_destroy (dialog);
+ } else {
+@@ -142,7 +142,7 @@ WlibApplySettings( GtkPrintOperation *op
+ dialog = gtk_message_dialog_new (GTK_WINDOW (gtkMainW->gtkwin),
+ GTK_DIALOG_DESTROY_WITH_PARENT,
+ GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE,
+- err->message);
++ "%s", err->message);
+ gtk_dialog_run (GTK_DIALOG (dialog));
+ gtk_widget_destroy (dialog);
+ } else {
+@@ -184,7 +184,7 @@ WlibSaveSettings( GtkPrintOperation *op
+ dialog = gtk_message_dialog_new (GTK_WINDOW (gtkMainW->gtkwin),
+ GTK_DIALOG_DESTROY_WITH_PARENT,
+ GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE,
+- err->message);
++ "%s", err->message);
+
+ g_error_free (err);
+ gtk_dialog_run (GTK_DIALOG (dialog));
+@@ -202,7 +202,7 @@ WlibSaveSettings( GtkPrintOperation *op
+ dialog = gtk_message_dialog_new (GTK_WINDOW (gtkMainW->gtkwin),
+ GTK_DIALOG_DESTROY_WITH_PARENT,
+ GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE,
+- err->message);
++ "%s", err->message);
+
+ g_error_free (err);
+ gtk_dialog_run (GTK_DIALOG (dialog));
+@@ -824,7 +824,7 @@ doPrintJobFinished( GtkPrintJob *job, vo
+ dialog = gtk_message_dialog_new (GTK_WINDOW (gtkMainW->gtkwin),
+ GTK_DIALOG_DESTROY_WITH_PARENT,
+ GTK_MESSAGE_ERROR, GTK_BUTTONS_CLOSE,
+- err->message);
++ "%s", err->message);
+ }
+ }
+
diff --git a/debian/patches/0700-info_file.patch b/debian/patches/0700-info_file.patch
new file mode 100644
index 0000000..01bfee2
--- /dev/null
+++ b/debian/patches/0700-info_file.patch
@@ -0,0 +1,18 @@
+Index: trunk/app/help/xtrkcad.info
+===================================================================
+--- trunk.orig/app/help/xtrkcad.info
++++ trunk/app/help/xtrkcad.info
+@@ -1,3 +1,8 @@
++INFO-DIR-SECTION CAD
++START-INFO-DIR-ENTRY
++* xtrkcad: xtrkcad-4.2.4. Model Train Track CAD Program
++END-INFO-DIR-ENTRY
++
+ :Help
+ Invokes on-line help for this dialog
+ :cancel
+@@ -1099,3 +1104,4 @@ Layer
+ :cmdLayerShow19
+ Layer
+ :
++
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..17dfafe
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+0700-info_file.patch
+0100-gtk.patch
diff --git a/debian/rules b/debian/rules
index 15b40e5..8aea7dc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,11 +11,9 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
override_dh_auto_configure:
dh_auto_configure -- \
- -DMAKE_BUILD_TYPE=RelWithDebInfo \
-DXTRKCAD_USE_GETTEXT=ON \
-DXTRKCAD_USE_GTK=ON \
- -DXTRKCAD_USE_GTK_CAIRO=ON \
- -DXTRKCAD_USE_LAYOUTCONTROL=ON
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr/
override_dh_install:
dh_install