summaryrefslogtreecommitdiff
path: root/distribution
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-28 20:24:50 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-28 20:24:50 +0100
commit09795a01ef859f072920de9df974d1b03b9ab9a4 (patch)
tree4d05907fc37f1bd781e506f5e196f7435aeec0ab /distribution
parent5b4163d8c76b03f0d31b09866aa4bd06b4d8d804 (diff)
New upstream version 4.2.4aupstream/4.2.4a
Diffstat (limited to 'distribution')
-rw-r--r--distribution/posix/CMakeLists.txt19
-rw-r--r--distribution/posix/package.txt8
-rw-r--r--distribution/posix/xtrkcad.spec84
3 files changed, 66 insertions, 45 deletions
diff --git a/distribution/posix/CMakeLists.txt b/distribution/posix/CMakeLists.txt
index daa89cf..8263645 100644
--- a/distribution/posix/CMakeLists.txt
+++ b/distribution/posix/CMakeLists.txt
@@ -1,17 +1,30 @@
# Setup packaging ...
SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "XTrackCAD is a CAD program for designing model railroad layouts.")
-SET(CPACK_GENERATOR "TGZ" "RPM" "TBZ2")
+SET(CPACK_GENERATOR "RPM" "STGZ")
+SET(CPACK_SOURCE_GENERATOR "TGZ" "TBZ2" "ZIP")
SET(CPACK_PACKAGE_RELEASE 1)
SET(CPACK_RPM_PACKAGE_LICENSE "GPL")
SET(CPACK_RPM_PACKAGE_GROUP "Applications/Engineering")
SET(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}////xtrkcad-desc.txt")
SET(CPACK_PACKAGE_FILE_NAME "xtrkcad-setup-${XTRKCAD_VERSION}-${CPACK_PACKAGE_RELEASE}.${CMAKE_SYSTEM_PROCESSOR}")
-SET(CPACK_INSTALL_PREFIX "/usr/local/" )
+
+SET(CPACK_INSTALL_PREFIX ${CMAKE_INSTALL_PREFIX} )
+SET(CPACK_PACKAGING_INSTALL_PREFIX ${CPACK_INSTALL_PREFIX})
+
+# get the specific configuration for each packager
+SET(CPACK_PROJECT_CONFIG_FILE ${CMAKE_CURRENT_SOURCE_DIR}/package.txt)
+
SET(CPACK_PACKAGE_VENDOR "XTrackCAD Fork Project")
SET(CPACK_RPM_PACKAGE_REQUIRES "glibc gtk2 webkitgtk")
# exclude these directories from the rpm
-SET(CPACK_RPM_EXCLUDE_FROM_AUTO_FILELIST_ADDITION "/usr/share/locale"
+SET(CPACK_RPM_EXCLUDE_FROM_AUTO_FILELIST_ADDITION
+ "/usr/local"
+ "/usr/local/share"
+ "/usr/local/bin"
+ "/usr/share/locale"
"/usr/share/locale/*"
+ "/usr/local/share/locale"
+ "/usr/local/share/locale/*"
)
SET(CPACK_RPM_CHANGELOG_FILE "${CMAKE_CURRENT_SOURCE_DIR}////changelog.txt")
diff --git a/distribution/posix/package.txt b/distribution/posix/package.txt
new file mode 100644
index 0000000..a4e925e
--- /dev/null
+++ b/distribution/posix/package.txt
@@ -0,0 +1,8 @@
+IF(CPACK_GENERATOR STREQUAL "TGZ" OR CPACK_GENERATOR STREQUAL "TBZ2")
+ set(CPACK_PACKAGING_INSTALL_PREFIX "")
+ELSEIF (CPACK_GENERATOR STREQUAL "RPM" )
+ set(CPACK_PACKAGING_INSTALL_PREFIX ${CPACK_INSTALL_PREFIX})
+ELSEIF (CPACK_GENERATOR STREQUAL "STGZ")
+ set(CPACK_PACKAGING_INSTALL_PREFIX "")
+ENDIF()
+
diff --git a/distribution/posix/xtrkcad.spec b/distribution/posix/xtrkcad.spec
index 4f5e72e..0d78736 100644
--- a/distribution/posix/xtrkcad.spec
+++ b/distribution/posix/xtrkcad.spec
@@ -1,42 +1,42 @@
-Summary: XTrkCad
-Name: xtrkcad
-Version: 4.2.1
-Release: 1%{?dist}
-License: GPL
-Group: Applications/Engineering
-Vendor: XTrkCad Fork Project
-Source: xtrkcad-source-%{version}.tar.gz
-BuildRoot: /var/tmp/%{name}-root
-BuildRequires: gcc, cmake >= 2.4.7, pkgconfig, gtk2-devel, webkitgtk-devel
-BuildRequires: gettext, gettext-devel, glibc-devel
-%description
-XTrkCad is a CAD program for designing Model Railroad layouts.
-XTrkCad supports any scale, has libraries of popular brands of x
-turnouts and sectional track (plus you add your own easily), can
-automatically use spiral transition curves when joining track
-XTrkCad lets you manipulate track much like you would with actual
-flex-track to modify, extend and join tracks and turnouts.
-Additional features include tunnels, 'post-it' notes, on-screen
-ruler, parts list, 99 drawing layers, undo/redo commands,
-benchwork, 'Print to BitMap', elevations, train simulation and
-car inventory.
-
-%prep
-%setup -n xtrkcad-source-%{version} -q
-
-%build
-cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr/ .
-make
-
-%install
-rm -rf $RPM_BUILD_ROOT/*
-make DESTDIR=$RPM_BUILD_ROOT install
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%files
-%defattr(-, root, root)
-%{_bindir}/xtrkcad
-%{_datadir}
-
+Summary: XTrkCad
+Name: xtrkcad
+Version: 4.2.3
+Release: 1%{?dist}
+License: GPL
+Group: Applications/Engineering
+Vendor: XTrkCad Fork Project
+Source: xtrkcad-source-%{version}.tar.gz
+BuildRoot: /var/tmp/%{name}-root
+BuildRequires: gcc, cmake >= 2.4.7, pkgconfig, gtk2-devel, webkitgtk-devel
+BuildRequires: gettext, gettext-devel, glibc-devel
+%description
+XTrkCad is a CAD program for designing Model Railroad layouts.
+XTrkCad supports any scale, has libraries of popular brands of x
+turnouts and sectional track (plus you add your own easily), can
+automatically use spiral transition curves when joining track
+XTrkCad lets you manipulate track much like you would with actual
+flex-track to modify, extend and join tracks and turnouts.
+Additional features include tunnels, 'post-it' notes, on-screen
+ruler, parts list, 99 drawing layers, undo/redo commands,
+benchwork, 'Print to BitMap', elevations, train simulation and
+car inventory.
+
+%prep
+%setup -n xtrkcad-source-%{version} -q
+
+%build
+cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr/ .
+make
+
+%install
+rm -rf $RPM_BUILD_ROOT/*
+make DESTDIR=$RPM_BUILD_ROOT install
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-, root, root)
+%{_bindir}/xtrkcad
+%{_datadir}
+