summaryrefslogtreecommitdiff
path: root/distribution
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-19 19:55:58 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2018-03-19 19:55:58 +0100
commitd1a8285f818eb7e5c3d6a05709ea21a808490b8c (patch)
tree326578f0505cbed07cfe60de530022822dc237ac /distribution
parent16e9630b79f0a7a90c6cedb6781175bb8b337dc1 (diff)
New upstream version 5.1.0upstream/5.1.0
Diffstat (limited to 'distribution')
-rw-r--r--distribution/CMakeLists.txt2
-rw-r--r--distribution/downloadpage.wiki.in46
-rw-r--r--distribution/osx/gtk-bundle/CMakeLists.txt2
-rw-r--r--distribution/osx/gtk-bundle/gtk-bundle.README21
-rw-r--r--distribution/posix/CMakeLists.txt45
-rw-r--r--distribution/posix/xtrkcad.spec5
-rw-r--r--distribution/win32/nsis/install.nsh6
7 files changed, 91 insertions, 36 deletions
diff --git a/distribution/CMakeLists.txt b/distribution/CMakeLists.txt
index e97a4a4..fc63769 100644
--- a/distribution/CMakeLists.txt
+++ b/distribution/CMakeLists.txt
@@ -14,6 +14,8 @@ SET(CPACK_RESOURCE_FILE_LICENSE "${XTrkCAD_SOURCE_DIR}/app/COPYING")
SET(CPACK_SOURCE_GENERATOR "ZIP;TGZ")
SET(CPACK_SOURCE_PACKAGE_FILE_NAME "xtrkcad-source-${XTRKCAD_VERSION}")
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/downloadpage.wiki.in ${CMAKE_BINARY_DIR}/downloadpage.wiki)
+
# Setup platform-specific packaging ...
IF(APPLE)
ADD_SUBDIRECTORY(osx)
diff --git a/distribution/downloadpage.wiki.in b/distribution/downloadpage.wiki.in
new file mode 100644
index 0000000..2d65511
--- /dev/null
+++ b/distribution/downloadpage.wiki.in
@@ -0,0 +1,46 @@
+======Download ""XTrackCAD"" Version @XTRKCAD_VERSION@======
+=====Install (Binary) Packages=====
+|=|OS|=|Download Package||
+||Windows||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad-setup-@XTRKCAD_VERSION@.exe/download Windows Installer (32 Bit) ]]||
+||Mac OSX||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad-OSX-V@XTRKCAD_VERSION@.dmg/download OSX Installer (64 Bit) ]]||
+||(y:4)Linux||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad-setup-@XTRKCAD_VERSION@-1.i686.rpm/download Fedora RPM (32 Bit) ]]||
+||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad-setup-@XTRKCAD_VERSION@-1.i686.sh/download self-extracting install script (32 Bit) ]]||
+||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad-setup-@XTRKCAD_VERSION@-1.x86_64.rpm/download Fedora RPM (64 Bit) ]]||
+||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad-setup-@XTRKCAD_VERSION@-1.x86_64.sh/download self-extracting install script (64 Bit) ]]||
+=====Third Party Packages=====
+Robert Heller created a few additional packets for Raspbian, Ubuntu 14.04+, and EL6. Files are up at:
+
+[[http://files.deepsoft.com/Other/xtrkcad/]]
+or
+[[ftp://ftp.deepsoft.com/pub/deepwoods/Other/xtrkcad/]]
+
+====""MacOSX""====
+ - ""MacOSX"" There is a new package available as linked above with a simplified install.
+ - Please see instructions for extra install steps at [[MacOSX]]
+=====Source Code=====
+|=|Format|=|Download||
+||TGZ||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad-source-@XTRKCAD_VERSION@.tar.gz/download GZipped Tar Archive]]||
+||BZ2||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad-source-@XTRKCAD_VERSION@.tar.bz2/download BZipped2 Tar Archive]]||
+||ZIP||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad-source-@XTRKCAD_VERSION@.zip/download ZIP Archive]]||
+||Mercurial Bundle||[[http://sourceforge.net/projects/xtrkcad-fork/files/XTrackCad/Version%20@XTRKCAD_MAJOR_VERSION@.@XTRKCAD_MINOR_VERSION@.@XTRKCAD_RELEASE_VERSION@/xtrkcad_@XTRKCAD_MAJOR_VERSION@_@XTRKCAD_MINOR_VERSION@_@XTRKCAD_RELEASE_VERSION@@XTRKCAD_VERSIONMODIFIER@.hg/download Mercurial bundle]]||
+
+The Mercurial bundle provides a downloadable starting point for developers who are on bandwidth constrained / flakey connections.
+To use the .hg bundle download xtrkcad_@XTRKCAD_MAJOR_VERSION@_@XTRKCAD_MINOR_VERSION@_@XTRKCAD_RELEASE_VERSION@@XTRKCAD_VERSIONMODIFIER@.hg and perform the following steps:
+%%
+mkdir xtrkcad
+cd xtrkcad
+hg init
+hg unbundle ../xtrkcad_@XTRKCAD_MAJOR_VERSION@_@XTRKCAD_MINOR_VERSION@_@XTRKCAD_RELEASE_VERSION@@XTRKCAD_VERSIONMODIFIER@
+edit .hg/hgrc adding these lines:
+
+[paths]
+default = http://hg.code.sf.net/p/xtrkcad-fork/xtrkcad
+%%
+Optionally do an hg pull then hg update to get the latest changes.
+
+""XTrackCAD"" has been compiled and tested on ""FreeBSD"" and ""OpenSolaris"". But there is no official support for these operating systems.
+
+====Older Versions====
+For your convenience, older versions of ""XTrackCAD"" can be downloaded from [[DownloadPage here]].
+----
+CategoryUser \ No newline at end of file
diff --git a/distribution/osx/gtk-bundle/CMakeLists.txt b/distribution/osx/gtk-bundle/CMakeLists.txt
index 4aa1150..f93ad9c 100644
--- a/distribution/osx/gtk-bundle/CMakeLists.txt
+++ b/distribution/osx/gtk-bundle/CMakeLists.txt
@@ -11,7 +11,7 @@ DESTINATION ${XTRKCAD_SHARE_INSTALL_DIR}/XTrackCAD.help
)
INSTALL (
FILES ${CMAKE_CURRENT_SOURCE_DIR}/toc.js
-DESTINATION ${XTRKCAD_SHARE_INSTALL_DIR}/XTrackCAD.help/Contents/Resources/en.lproj
+DESTINATION ${XTRKCAD_SHARE_INSTALL_DIR}/XTrackCAD.help/Contents/Resources/en.lproj/scrpt
)
ADD_SUBDIRECTORY(XTrackCAD-help)
diff --git a/distribution/osx/gtk-bundle/gtk-bundle.README b/distribution/osx/gtk-bundle/gtk-bundle.README
index 139cec7..0c7c9ea 100644
--- a/distribution/osx/gtk-bundle/gtk-bundle.README
+++ b/distribution/osx/gtk-bundle/gtk-bundle.README
@@ -1,7 +1,7 @@
Readme for gtk-bundle directory.
Created 12-1-2016 by Adam Richards
-Date: Dec-2016.
+Date: Nov-2017.
The gtk-bundle technique replaces prior bundle techniques for OSX.
@@ -13,30 +13,25 @@ The bundler also requires a prior Macports install of GTK
"sudo port install webkit-gtk"
and that was the GTK level was used to build the xtrkcad binary.
-The ccmake process will place a copy of the binary in the /bin build subdirectory
+The ccmake install process will place a copy of the binary in the /bin install subdirectory
for use by G-M-B. It also copies over the resource share libraries into a subdirectory.
Process:
-Once ccmake has been run "make" followed by "make install", the G-M-B tool is run
-pointing at the xtrkcad.bundle file.
+Once ccmake has been run "make" followed by "make install", the G-M-B tool is run.
"cd /gtk-bundle"
-"gtk-mac-bundler xtrkcad-bundle"
+"bash xtrkcad-bundler.sh -i <install directory containing xtrkcad binary> -v <version name>"
Output:
-G-M-B produces an .app bundle that is a self-contained executable
-from the binary xtrkcad in gtk-bundle/bin. It recursively rewires all the link pointers to be
+G-M-B produces a dmg bundle and zips it in the binary directory that is a self-contained executable
+from the binary xtrkcad. It recursively rewires all the link pointers to be
self-referential - that is, to point within the bundle.
It uses the xtrkcad.plist to set properties of the app, including the
icon from the .icns file. It sets the pre-run script to be xtrkcad-launcher.sh
Next Steps:
-Once this xtrkcad.app file has been created, it can be moved to wherever is desirable
-- such as the Application folder. The app does not have dependencies on GTK components
-from MACPorts like the binary does - it is standalone.
-
-To produce an installable image from the .app, the disk utility can be used to create
-a RW image .dmg that the .app can be copied into.
+Once this xtrkcad.dmg file has been created, it can be opened and the included package can be moved to wherever is desirable - such as the Application folder. The app does not have dependencies on GTK components
+from MACPorts like the binary does - it is standalone. It does, however, need XQuartz.
NOTE -
It is expected that as long as the GTK level used in build can run on the OSX level used
diff --git a/distribution/posix/CMakeLists.txt b/distribution/posix/CMakeLists.txt
index 7a0ee50..96636b0 100644
--- a/distribution/posix/CMakeLists.txt
+++ b/distribution/posix/CMakeLists.txt
@@ -1,23 +1,32 @@
# Setup packaging ...
-SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "XTrackCAD is a CAD program for designing model railroad layouts.")
-SET(CPACK_GENERATOR "RPM" "STGZ")
-SET(CPACK_SOURCE_GENERATOR "TGZ" "TBZ2" "ZIP")
-SET(CPACK_PACKAGE_RELEASE 1)
-SET(CPACK_RPM_PACKAGE_LICENSE "GPL")
-SET(CPACK_RPM_PACKAGE_GROUP "Applications/Engineering")
-SET(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}////xtrkcad-desc.txt")
-SET(CPACK_PACKAGE_FILE_NAME "xtrkcad-setup-${XTRKCAD_VERSION}-${CPACK_PACKAGE_RELEASE}.${CMAKE_SYSTEM_PROCESSOR}")
-
-SET(CPACK_INSTALL_PREFIX ${CMAKE_INSTALL_PREFIX} )
-SET(CPACK_PACKAGING_INSTALL_PREFIX ${CPACK_INSTALL_PREFIX})
+set(CPACK_PACKAGE_DESCRIPTION_SUMMARY "XTrackCAD is a CAD program for designing model railroad layouts.")
+set(CPACK_GENERATOR "RPM" "STGZ")
+set(CPACK_SOURCE_GENERATOR "TGZ" "TBZ2" "ZIP")
+set(CPACK_PACKAGE_RELEASE 1)
+set(CPACK_RPM_PACKAGE_LICENSE "GPL")
+set(CPACK_RPM_PACKAGE_GROUP "Applications/Engineering")
+set(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}////xtrkcad-desc.txt")
+set(CPACK_PACKAGE_FILE_NAME "xtrkcad-setup-${XTRKCAD_VERSION}-${CPACK_PACKAGE_RELEASE}.${CMAKE_SYSTEM_PROCESSOR}")
+
+set(CPACK_INSTALL_PREFIX ${CMAKE_INSTALL_PREFIX} )
+set(CPACK_PACKAGING_INSTALL_PREFIX ${CPACK_INSTALL_PREFIX})
# get the specific configuration for each packager
-SET(CPACK_PROJECT_CONFIG_FILE ${CMAKE_CURRENT_SOURCE_DIR}/package.txt)
+set(CPACK_PROJECT_CONFIG_FILE ${CMAKE_CURRENT_SOURCE_DIR}/package.txt)
+
+set(CPACK_PACKAGE_VENDOR "XTrackCAD Fork Project")
+
+# common dependencies for all Linux builds
+set(CPACK_RPM_PACKAGE_REQUIRES "glibc gtk2")
+
+# Add dependency to webkitgtk if configured
+if(NOT XTRKCAD_USE_BROWSER)
+ set(CPACK_RPM_PACKAGE_REQUIRES
+ "${CPACK_RPM_PACKAGE_REQUIRES} webkitgtk")
+endif()
-SET(CPACK_PACKAGE_VENDOR "XTrackCAD Fork Project")
-SET(CPACK_RPM_PACKAGE_REQUIRES "glibc gtk2 webkitgtk")
-# exclude these directories from the rpm
-SET(CPACK_RPM_EXCLUDE_FROM_AUTO_FILELIST_ADDITION
+# exclude these directories from the rpm
+set(CPACK_RPM_EXCLUDE_FROM_AUTO_FILELIST_ADDITION
"/usr/local"
"/usr/local/share"
"/usr/local/bin"
@@ -29,7 +38,7 @@ SET(CPACK_RPM_EXCLUDE_FROM_AUTO_FILELIST_ADDITION
"/usr/share/pixmaps"
)
-SET(CPACK_RPM_CHANGELOG_FILE "${CMAKE_CURRENT_SOURCE_DIR}////changelog.txt")
+set(CPACK_RPM_CHANGELOG_FILE "${CMAKE_CURRENT_SOURCE_DIR}////changelog.txt")
-INCLUDE(CPack)
+include(CPack)
diff --git a/distribution/posix/xtrkcad.spec b/distribution/posix/xtrkcad.spec
index f94976a..a7f6033 100644
--- a/distribution/posix/xtrkcad.spec
+++ b/distribution/posix/xtrkcad.spec
@@ -1,7 +1,7 @@
Summary: XTrkCad
Name: xtrkcad
-Version: 4.2.4a
-Release: 4%{?dist}
+Version: 4.3.0
+Release: 1%{?dist}
License: GPL
Group: Applications/Engineering
Vendor: XTrkCad Fork Project
@@ -37,6 +37,7 @@ rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
+%defattr(755, root, root) /usr/local/share/xtrkcad/xdg-open
%{_bindir}/xtrkcad
%{_datadir}
diff --git a/distribution/win32/nsis/install.nsh b/distribution/win32/nsis/install.nsh
index 9f14625..dc4ed80 100644
--- a/distribution/win32/nsis/install.nsh
+++ b/distribution/win32/nsis/install.nsh
@@ -2,8 +2,10 @@
; This file is included from the CMake generated NSIS file during install.
;
-CreateShortCut "$SMPROGRAMS\$STARTMENU_FOLDER\XTrkCad Help.lnk" "$INSTDIR\share\xtrkcad\xtrkcad.chm" "" "" 0
-CreateShortCut "$SMPROGRAMS\$STARTMENU_FOLDER\XTrkCad ReadMe.lnk" "notepad.exe" "$INSTDIR\share\xtrkcad\ReadMe.txt"
+CreateShortCut "$SMPROGRAMS\$STARTMENU_FOLDER\XTrackCAD Help.lnk" "$INSTDIR\share\xtrkcad\xtrkcad.chm" "" "" 0
+CreateShortCut "$SMPROGRAMS\$STARTMENU_FOLDER\XTrackCAD ReadMe.lnk" "notepad.exe" "$INSTDIR\share\xtrkcad\ReadMe.txt"
+CreateShortCut "$SMPROGRAMS\$STARTMENU_FOLDER\XTrackCAD CHANGELOG.lnk" "notepad.exe" "$INSTDIR\share\xtrkcad\CHANGELOG.txt"
+
;
; create file association