summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile624
1 files changed, 0 insertions, 624 deletions
diff --git a/Makefile b/Makefile
deleted file mode 100644
index bcb2bd4..0000000
--- a/Makefile
+++ /dev/null
@@ -1,624 +0,0 @@
-# CMAKE generated file: DO NOT EDIT!
-# Generated by "Unix Makefiles" Generator, CMake Version 3.6
-
-# Default target executed when no arguments are given to make.
-default_target: all
-
-.PHONY : default_target
-
-# Allow only one "make -f Makefile2" at a time, but pass parallelism.
-.NOTPARALLEL:
-
-
-#=============================================================================
-# Special targets provided by cmake.
-
-# Disable implicit rules so canonical targets will work.
-.SUFFIXES:
-
-
-# Remove some rules from gmake that .SUFFIXES does not remove.
-SUFFIXES =
-
-.SUFFIXES: .hpux_make_needs_suffix_list
-
-
-# Suppress display of executed commands.
-$(VERBOSE).SILENT:
-
-
-# A target that is always out of date.
-cmake_force:
-
-.PHONY : cmake_force
-
-#=============================================================================
-# Set environment variables for the build.
-
-# The shell in which to execute make rules.
-SHELL = /bin/sh
-
-# The CMake executable.
-CMAKE_COMMAND = /usr/bin/cmake
-
-# The command to remove a file.
-RM = /usr/bin/cmake -E remove -f
-
-# Escaping for special characters.
-EQUALS = =
-
-# The top-level source directory on which CMake was run.
-CMAKE_SOURCE_DIR = /home/martin/XTrackCAD/src/work
-
-# The top-level build directory on which CMake was run.
-CMAKE_BINARY_DIR = /home/martin/XTrackCAD/src/work
-
-#=============================================================================
-# Targets provided globally by CMake.
-
-# Special rule for the target edit_cache
-edit_cache:
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running CMake cache editor..."
- /usr/bin/ccmake -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR)
-.PHONY : edit_cache
-
-# Special rule for the target edit_cache
-edit_cache/fast: edit_cache
-
-.PHONY : edit_cache/fast
-
-# Special rule for the target install/strip
-install/strip: preinstall
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing the project stripped..."
- /usr/bin/cmake -DCMAKE_INSTALL_DO_STRIP=1 -P cmake_install.cmake
-.PHONY : install/strip
-
-# Special rule for the target install/strip
-install/strip/fast: install/strip
-
-.PHONY : install/strip/fast
-
-# Special rule for the target test
-test:
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running tests..."
- /usr/bin/ctest --force-new-ctest-process $(ARGS)
-.PHONY : test
-
-# Special rule for the target test
-test/fast: test
-
-.PHONY : test/fast
-
-# Special rule for the target package_source
-package_source:
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Run CPack packaging tool for source..."
- /usr/bin/cpack --config ./CPackSourceConfig.cmake /home/martin/XTrackCAD/src/work/CPackSourceConfig.cmake
-.PHONY : package_source
-
-# Special rule for the target package_source
-package_source/fast: package_source
-
-.PHONY : package_source/fast
-
-# Special rule for the target package
-package: preinstall
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Run CPack packaging tool..."
- /usr/bin/cpack --config ./CPackConfig.cmake
-.PHONY : package
-
-# Special rule for the target package
-package/fast: package
-
-.PHONY : package/fast
-
-# Special rule for the target install/local
-install/local: preinstall
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing only the local directory..."
- /usr/bin/cmake -DCMAKE_INSTALL_LOCAL_ONLY=1 -P cmake_install.cmake
-.PHONY : install/local
-
-# Special rule for the target install/local
-install/local/fast: install/local
-
-.PHONY : install/local/fast
-
-# Special rule for the target install
-install: preinstall
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Install the project..."
- /usr/bin/cmake -P cmake_install.cmake
-.PHONY : install
-
-# Special rule for the target install
-install/fast: preinstall/fast
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Install the project..."
- /usr/bin/cmake -P cmake_install.cmake
-.PHONY : install/fast
-
-# Special rule for the target list_install_components
-list_install_components:
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Available install components are: \"Unspecified\""
-.PHONY : list_install_components
-
-# Special rule for the target list_install_components
-list_install_components/fast: list_install_components
-
-.PHONY : list_install_components/fast
-
-# Special rule for the target rebuild_cache
-rebuild_cache:
- @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running CMake to regenerate build system..."
- /usr/bin/cmake -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR)
-.PHONY : rebuild_cache
-
-# Special rule for the target rebuild_cache
-rebuild_cache/fast: rebuild_cache
-
-.PHONY : rebuild_cache/fast
-
-# The main all target
-all: cmake_check_build_system
- $(CMAKE_COMMAND) -E cmake_progress_start /home/martin/XTrackCAD/src/work/CMakeFiles /home/martin/XTrackCAD/src/work/CMakeFiles/progress.marks
- $(MAKE) -f CMakeFiles/Makefile2 all
- $(CMAKE_COMMAND) -E cmake_progress_start /home/martin/XTrackCAD/src/work/CMakeFiles 0
-.PHONY : all
-
-# The main clean target
-clean:
- $(MAKE) -f CMakeFiles/Makefile2 clean
-.PHONY : clean
-
-# The main clean target
-clean/fast: clean
-
-.PHONY : clean/fast
-
-# Prepare targets for installation.
-preinstall: all
- $(MAKE) -f CMakeFiles/Makefile2 preinstall
-.PHONY : preinstall
-
-# Prepare targets for installation.
-preinstall/fast:
- $(MAKE) -f CMakeFiles/Makefile2 preinstall
-.PHONY : preinstall/fast
-
-# clear depends
-depend:
- $(CMAKE_COMMAND) -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 1
-.PHONY : depend
-
-#=============================================================================
-# Target rules for targets named dynstring
-
-# Build rule for target.
-dynstring: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 dynstring
-.PHONY : dynstring
-
-# fast build rule for target.
-dynstring/fast:
- $(MAKE) -f app/dynstring/CMakeFiles/dynstring.dir/build.make app/dynstring/CMakeFiles/dynstring.dir/build
-.PHONY : dynstring/fast
-
-#=============================================================================
-# Target rules for targets named dynstringtest
-
-# Build rule for target.
-dynstringtest: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 dynstringtest
-.PHONY : dynstringtest
-
-# fast build rule for target.
-dynstringtest/fast:
- $(MAKE) -f app/dynstring/unittest/CMakeFiles/dynstringtest.dir/build.make app/dynstring/unittest/CMakeFiles/dynstringtest.dir/build
-.PHONY : dynstringtest/fast
-
-#=============================================================================
-# Target rules for targets named xtrkcad-wlib
-
-# Build rule for target.
-xtrkcad-wlib: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 xtrkcad-wlib
-.PHONY : xtrkcad-wlib
-
-# fast build rule for target.
-xtrkcad-wlib/fast:
- $(MAKE) -f app/wlib/gtklib/CMakeFiles/xtrkcad-wlib.dir/build.make app/wlib/gtklib/CMakeFiles/xtrkcad-wlib.dir/build
-.PHONY : xtrkcad-wlib/fast
-
-#=============================================================================
-# Target rules for targets named listxtp
-
-# Build rule for target.
-listxtp: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 listxtp
-.PHONY : listxtp
-
-# fast build rule for target.
-listxtp/fast:
- $(MAKE) -f app/tools/CMakeFiles/listxtp.dir/build.make app/tools/CMakeFiles/listxtp.dir/build
-.PHONY : listxtp/fast
-
-#=============================================================================
-# Target rules for targets named halibut
-
-# Build rule for target.
-halibut: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 halibut
-.PHONY : halibut
-
-# fast build rule for target.
-halibut/fast:
- $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/build
-.PHONY : halibut/fast
-
-#=============================================================================
-# Target rules for targets named xtrkcad-charset
-
-# Build rule for target.
-xtrkcad-charset: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 xtrkcad-charset
-.PHONY : xtrkcad-charset
-
-# fast build rule for target.
-xtrkcad-charset/fast:
- $(MAKE) -f app/tools/halibut/charset/CMakeFiles/xtrkcad-charset.dir/build.make app/tools/halibut/charset/CMakeFiles/xtrkcad-charset.dir/build
-.PHONY : xtrkcad-charset/fast
-
-#=============================================================================
-# Target rules for targets named Help
-
-# Build rule for target.
-Help: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 Help
-.PHONY : Help
-
-# fast build rule for target.
-Help/fast:
- $(MAKE) -f app/help/CMakeFiles/Help.dir/build.make app/help/CMakeFiles/Help.dir/build
-.PHONY : Help/fast
-
-#=============================================================================
-# Target rules for targets named genhelp
-
-# Build rule for target.
-genhelp: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 genhelp
-.PHONY : genhelp
-
-# fast build rule for target.
-genhelp/fast:
- $(MAKE) -f app/help/CMakeFiles/genhelp.dir/build.make app/help/CMakeFiles/genhelp.dir/build
-.PHONY : genhelp/fast
-
-#=============================================================================
-# Target rules for targets named genmessages
-
-# Build rule for target.
-genmessages: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 genmessages
-.PHONY : genmessages
-
-# fast build rule for target.
-genmessages/fast:
- $(MAKE) -f app/help/CMakeFiles/genmessages.dir/build.make app/help/CMakeFiles/genmessages.dir/build
-.PHONY : genmessages/fast
-
-#=============================================================================
-# Target rules for targets named help-html
-
-# Build rule for target.
-help-html: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 help-html
-.PHONY : help-html
-
-# fast build rule for target.
-help-html/fast:
- $(MAKE) -f app/doc/CMakeFiles/help-html.dir/build.make app/doc/CMakeFiles/help-html.dir/build
-.PHONY : help-html/fast
-
-#=============================================================================
-# Target rules for targets named clean-html
-
-# Build rule for target.
-clean-html: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 clean-html
-.PHONY : clean-html
-
-# fast build rule for target.
-clean-html/fast:
- $(MAKE) -f app/doc/CMakeFiles/clean-html.dir/build.make app/doc/CMakeFiles/clean-html.dir/build
-.PHONY : clean-html/fast
-
-#=============================================================================
-# Target rules for targets named xtrkcad
-
-# Build rule for target.
-xtrkcad: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 xtrkcad
-.PHONY : xtrkcad
-
-# fast build rule for target.
-xtrkcad/fast:
- $(MAKE) -f app/bin/CMakeFiles/xtrkcad.dir/build.make app/bin/CMakeFiles/xtrkcad.dir/build
-.PHONY : xtrkcad/fast
-
-#=============================================================================
-# Target rules for targets named xtrkcad-lib
-
-# Build rule for target.
-xtrkcad-lib: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 xtrkcad-lib
-.PHONY : xtrkcad-lib
-
-# fast build rule for target.
-xtrkcad-lib/fast:
- $(MAKE) -f app/bin/CMakeFiles/xtrkcad-lib.dir/build.make app/bin/CMakeFiles/xtrkcad-lib.dir/build
-.PHONY : xtrkcad-lib/fast
-
-#=============================================================================
-# Target rules for targets named mkturnout
-
-# Build rule for target.
-mkturnout: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 mkturnout
-.PHONY : mkturnout
-
-# fast build rule for target.
-mkturnout/fast:
- $(MAKE) -f app/bin/CMakeFiles/mkturnout.dir/build.make app/bin/CMakeFiles/mkturnout.dir/build
-.PHONY : mkturnout/fast
-
-#=============================================================================
-# Target rules for targets named cnvdsgn
-
-# Build rule for target.
-cnvdsgn: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 cnvdsgn
-.PHONY : cnvdsgn
-
-# fast build rule for target.
-cnvdsgn/fast:
- $(MAKE) -f app/bin/CMakeFiles/cnvdsgn.dir/build.make app/bin/CMakeFiles/cnvdsgn.dir/build
-.PHONY : cnvdsgn/fast
-
-#=============================================================================
-# Target rules for targets named defaultstest
-
-# Build rule for target.
-defaultstest: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 defaultstest
-.PHONY : defaultstest
-
-# fast build rule for target.
-defaultstest/fast:
- $(MAKE) -f app/bin/unittest/CMakeFiles/defaultstest.dir/build.make app/bin/unittest/CMakeFiles/defaultstest.dir/build
-.PHONY : defaultstest/fast
-
-#=============================================================================
-# Target rules for targets named pathstest
-
-# Build rule for target.
-pathstest: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 pathstest
-.PHONY : pathstest
-
-# fast build rule for target.
-pathstest/fast:
- $(MAKE) -f app/bin/unittest/CMakeFiles/pathstest.dir/build.make app/bin/unittest/CMakeFiles/pathstest.dir/build
-.PHONY : pathstest/fast
-
-#=============================================================================
-# Target rules for targets named dxfformattest
-
-# Build rule for target.
-dxfformattest: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 dxfformattest
-.PHONY : dxfformattest
-
-# fast build rule for target.
-dxfformattest/fast:
- $(MAKE) -f app/bin/unittest/CMakeFiles/dxfformattest.dir/build.make app/bin/unittest/CMakeFiles/dxfformattest.dir/build
-.PHONY : dxfformattest/fast
-
-#=============================================================================
-# Target rules for targets named Readme
-
-# Build rule for target.
-Readme: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 Readme
-.PHONY : Readme
-
-# fast build rule for target.
-Readme/fast:
- $(MAKE) -f app/lib/CMakeFiles/Readme.dir/build.make app/lib/CMakeFiles/Readme.dir/build
-.PHONY : Readme/fast
-
-#=============================================================================
-# Target rules for targets named CHANGELOG
-
-# Build rule for target.
-CHANGELOG: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 CHANGELOG
-.PHONY : CHANGELOG
-
-# fast build rule for target.
-CHANGELOG/fast:
- $(MAKE) -f app/lib/CMakeFiles/CHANGELOG.dir/build.make app/lib/CMakeFiles/CHANGELOG.dir/build
-.PHONY : CHANGELOG/fast
-
-#=============================================================================
-# Target rules for targets named xtpfiles
-
-# Build rule for target.
-xtpfiles: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 xtpfiles
-.PHONY : xtpfiles
-
-# fast build rule for target.
-xtpfiles/fast:
- $(MAKE) -f app/lib/params/CMakeFiles/xtpfiles.dir/build.make app/lib/params/CMakeFiles/xtpfiles.dir/build
-.PHONY : xtpfiles/fast
-
-#=============================================================================
-# Target rules for targets named mkstruct
-
-# Build rule for target.
-mkstruct: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 mkstruct
-.PHONY : mkstruct
-
-# fast build rule for target.
-mkstruct/fast:
- $(MAKE) -f app/lib/params/CMakeFiles/mkstruct.dir/build.make app/lib/params/CMakeFiles/mkstruct.dir/build
-.PHONY : mkstruct/fast
-
-#=============================================================================
-# Target rules for targets named mkcarpart
-
-# Build rule for target.
-mkcarpart: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 mkcarpart
-.PHONY : mkcarpart
-
-# fast build rule for target.
-mkcarpart/fast:
- $(MAKE) -f app/lib/params/CMakeFiles/mkcarpart.dir/build.make app/lib/params/CMakeFiles/mkcarpart.dir/build
-.PHONY : mkcarpart/fast
-
-#=============================================================================
-# Target rules for targets named xtrkcad-cornu
-
-# Build rule for target.
-xtrkcad-cornu: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 xtrkcad-cornu
-.PHONY : xtrkcad-cornu
-
-# fast build rule for target.
-xtrkcad-cornu/fast:
- $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/build
-.PHONY : xtrkcad-cornu/fast
-
-#=============================================================================
-# Target rules for targets named messages
-
-# Build rule for target.
-messages: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 messages
-.PHONY : messages
-
-# fast build rule for target.
-messages/fast:
- $(MAKE) -f app/i18n/CMakeFiles/messages.dir/build.make app/i18n/CMakeFiles/messages.dir/build
-.PHONY : messages/fast
-
-#=============================================================================
-# Target rules for targets named msgmerge-pt_BR
-
-# Build rule for target.
-msgmerge-pt_BR: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 msgmerge-pt_BR
-.PHONY : msgmerge-pt_BR
-
-# fast build rule for target.
-msgmerge-pt_BR/fast:
- $(MAKE) -f app/i18n/CMakeFiles/msgmerge-pt_BR.dir/build.make app/i18n/CMakeFiles/msgmerge-pt_BR.dir/build
-.PHONY : msgmerge-pt_BR/fast
-
-#=============================================================================
-# Target rules for targets named msgmerge-fi
-
-# Build rule for target.
-msgmerge-fi: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 msgmerge-fi
-.PHONY : msgmerge-fi
-
-# fast build rule for target.
-msgmerge-fi/fast:
- $(MAKE) -f app/i18n/CMakeFiles/msgmerge-fi.dir/build.make app/i18n/CMakeFiles/msgmerge-fi.dir/build
-.PHONY : msgmerge-fi/fast
-
-#=============================================================================
-# Target rules for targets named msgmerge-de_DE
-
-# Build rule for target.
-msgmerge-de_DE: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 msgmerge-de_DE
-.PHONY : msgmerge-de_DE
-
-# fast build rule for target.
-msgmerge-de_DE/fast:
- $(MAKE) -f app/i18n/CMakeFiles/msgmerge-de_DE.dir/build.make app/i18n/CMakeFiles/msgmerge-de_DE.dir/build
-.PHONY : msgmerge-de_DE/fast
-
-#=============================================================================
-# Target rules for targets named stripmsg
-
-# Build rule for target.
-stripmsg: cmake_check_build_system
- $(MAKE) -f CMakeFiles/Makefile2 stripmsg
-.PHONY : stripmsg
-
-# fast build rule for target.
-stripmsg/fast:
- $(MAKE) -f app/i18n/CMakeFiles/stripmsg.dir/build.make app/i18n/CMakeFiles/stripmsg.dir/build
-.PHONY : stripmsg/fast
-
-# Help Target
-help:
- @echo "The following are some of the valid targets for this Makefile:"
- @echo "... all (the default if no target is provided)"
- @echo "... clean"
- @echo "... depend"
- @echo "... edit_cache"
- @echo "... install/strip"
- @echo "... test"
- @echo "... package_source"
- @echo "... package"
- @echo "... install/local"
- @echo "... install"
- @echo "... list_install_components"
- @echo "... rebuild_cache"
- @echo "... dynstring"
- @echo "... dynstringtest"
- @echo "... xtrkcad-wlib"
- @echo "... listxtp"
- @echo "... halibut"
- @echo "... xtrkcad-charset"
- @echo "... Help"
- @echo "... genhelp"
- @echo "... genmessages"
- @echo "... help-html"
- @echo "... clean-html"
- @echo "... xtrkcad"
- @echo "... xtrkcad-lib"
- @echo "... mkturnout"
- @echo "... cnvdsgn"
- @echo "... defaultstest"
- @echo "... pathstest"
- @echo "... dxfformattest"
- @echo "... Readme"
- @echo "... CHANGELOG"
- @echo "... xtpfiles"
- @echo "... mkstruct"
- @echo "... mkcarpart"
- @echo "... xtrkcad-cornu"
- @echo "... messages"
- @echo "... msgmerge-pt_BR"
- @echo "... msgmerge-fi"
- @echo "... msgmerge-de_DE"
- @echo "... stripmsg"
-.PHONY : help
-
-
-
-#=============================================================================
-# Special targets to cleanup operation of make.
-
-# Special rule to run CMake to check the build system integrity.
-# No rule that depends on this can have commands that come from listfiles
-# because they might be regenerated.
-cmake_check_build_system:
- $(CMAKE_COMMAND) -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 0
-.PHONY : cmake_check_build_system
-