summaryrefslogtreecommitdiff
path: root/app/bin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/bin/CMakeLists.txt')
-rw-r--r--app/bin/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/app/bin/CMakeLists.txt b/app/bin/CMakeLists.txt
index 4bc9fdc..ee0886d 100644
--- a/app/bin/CMakeLists.txt
+++ b/app/bin/CMakeLists.txt
@@ -65,6 +65,7 @@ SET(SOURCES
bllnhlp.c
cblock.c
ccurve.c
+ ccontrol.c
cdraw.c
celev.c
cgroup.c
@@ -81,8 +82,10 @@ SET(SOURCES
cpull.c
cruler.c
cselect.c
+ csensor.c
csnap.c
csplit.c
+ csignal.c
cstraigh.c
cstruct.c
cswitchmotor.c
@@ -98,6 +101,7 @@ SET(SOURCES
dcar.c
dcmpnd.c
dcustmgm.c
+ dcontmgm.c
dease.c
denum.c
dlayer.c
@@ -106,6 +110,8 @@ SET(SOURCES
dprmfile.c
draw.c
drawgeom.c
+ dxfformat.c
+ dxfoutput.c
elev.c
fileio.c
i18n.c
@@ -148,6 +154,7 @@ ADD_EXECUTABLE(xtrkcad WIN32
)
TARGET_LINK_LIBRARIES(xtrkcad xtrkcad-lib)
TARGET_LINK_LIBRARIES(xtrkcad xtrkcad-wlib)
+target_link_libraries(xtrkcad dynstring)
ADD_EXECUTABLE(mkturnout
${LIN_SOURCES}
@@ -169,7 +176,23 @@ ELSE(NOT WIN32)
TARGET_LINK_LIBRARIES(mkturnout xtrkcad-wlib)
ENDIF(NOT WIN32)
+# for testing only, should be IF(APPLE) ...
+IF(APPLE)
+ ADD_EXECUTABLE( helphelper helphelper.c )
+ FIND_LIBRARY(COREFOUNDATION_LIBRARY CoreFoundation)
+ FIND_LIBRARY(CARBON_LIBRARY Carbon)
+ TARGET_lINK_LIBRARIES(helphelper ${COREFOUNDATION_LIBRARY} ${CARBON_LIBRARY})
+ INSTALL(
+ TARGETS helphelper
+ RUNTIME DESTINATION ${XTRKCAD_BIN_INSTALL_DIR}
+ )
+ENDIF(APPLE)
+
INSTALL(
TARGETS xtrkcad
RUNTIME DESTINATION ${XTRKCAD_BIN_INSTALL_DIR}
)
+
+if(XTRKCAD_TESTING AND CMOCKA_FOUND)
+ add_subdirectory( unittest )
+endif()