summaryrefslogtreecommitdiff
path: root/app/bin/unittest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/bin/unittest/CMakeLists.txt')
-rw-r--r--app/bin/unittest/CMakeLists.txt36
1 files changed, 34 insertions, 2 deletions
diff --git a/app/bin/unittest/CMakeLists.txt b/app/bin/unittest/CMakeLists.txt
index 32e2ddb..7055d0b 100644
--- a/app/bin/unittest/CMakeLists.txt
+++ b/app/bin/unittest/CMakeLists.txt
@@ -1,10 +1,10 @@
# build unit tests for the xtrkcad library
-add_executable(dxfformattest
+add_executable(dxfformattest
dxfformattest.c
../dxfformat.c
)
-
+
target_link_libraries(dxfformattest
dynstring
${LIBS})
@@ -29,3 +29,35 @@ target_link_libraries(defaultstest
${LIBS})
add_test(DefaultsTest defaultstest)
+
+add_executable(shortentest
+ shortentest.c
+ ../shortentext.c
+ )
+
+target_link_libraries(shortentest
+ ${LIBS})
+
+add_test(ShortenTest shortentest)
+
+add_test(CatalogTest catalogtest)
+
+set (TESTXTP
+ "atl83ho.xtp" "atlasn.xtp" "HO-Peco-Code83.xtp"
+ )
+
+foreach(testfile IN LISTS TESTXTP )
+ configure_file ( ${CMAKE_CURRENT_SOURCE_DIR}/testfiles/${testfile}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ COPYONLY )
+endforeach()
+
+add_executable(catalogtest
+ catalogtest.c
+ ../partcatalog.c
+ ../paths.c
+ )
+
+target_link_libraries(catalogtest
+ dynstring
+ ${LIBS}) \ No newline at end of file