summaryrefslogtreecommitdiff
path: root/app/bin/unittest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/bin/unittest/CMakeLists.txt')
-rw-r--r--app/bin/unittest/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/app/bin/unittest/CMakeLists.txt b/app/bin/unittest/CMakeLists.txt
new file mode 100644
index 0000000..b6d2bc5
--- /dev/null
+++ b/app/bin/unittest/CMakeLists.txt
@@ -0,0 +1,12 @@
+# build unit tests for the xtrkcad library
+
+add_executable(dxfformattest
+ dxfformattest.c
+ ../dxfformat.c
+ )
+
+target_link_libraries(dxfformattest
+ dynstring
+ ${LIBS})
+
+add_test(DXFOutputTest dxfformattest) \ No newline at end of file