summaryrefslogtreecommitdiff
path: root/app/cornu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'app/cornu/Makefile')
-rw-r--r--app/cornu/Makefile354
1 files changed, 354 insertions, 0 deletions
diff --git a/app/cornu/Makefile b/app/cornu/Makefile
new file mode 100644
index 0000000..edaf022
--- /dev/null
+++ b/app/cornu/Makefile
@@ -0,0 +1,354 @@
+# CMAKE generated file: DO NOT EDIT!
+# Generated by "Unix Makefiles" Generator, CMake Version 3.6
+
+# Default target executed when no arguments are given to make.
+default_target: all
+
+.PHONY : default_target
+
+# Allow only one "make -f Makefile2" at a time, but pass parallelism.
+.NOTPARALLEL:
+
+
+#=============================================================================
+# Special targets provided by cmake.
+
+# Disable implicit rules so canonical targets will work.
+.SUFFIXES:
+
+
+# Remove some rules from gmake that .SUFFIXES does not remove.
+SUFFIXES =
+
+.SUFFIXES: .hpux_make_needs_suffix_list
+
+
+# Suppress display of executed commands.
+$(VERBOSE).SILENT:
+
+
+# A target that is always out of date.
+cmake_force:
+
+.PHONY : cmake_force
+
+#=============================================================================
+# Set environment variables for the build.
+
+# The shell in which to execute make rules.
+SHELL = /bin/sh
+
+# The CMake executable.
+CMAKE_COMMAND = /usr/bin/cmake
+
+# The command to remove a file.
+RM = /usr/bin/cmake -E remove -f
+
+# Escaping for special characters.
+EQUALS = =
+
+# The top-level source directory on which CMake was run.
+CMAKE_SOURCE_DIR = /home/martin/XTrackCAD/src/work
+
+# The top-level build directory on which CMake was run.
+CMAKE_BINARY_DIR = /home/martin/XTrackCAD/src/work
+
+#=============================================================================
+# Targets provided globally by CMake.
+
+# Special rule for the target edit_cache
+edit_cache:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running CMake cache editor..."
+ /usr/bin/ccmake -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR)
+.PHONY : edit_cache
+
+# Special rule for the target edit_cache
+edit_cache/fast: edit_cache
+
+.PHONY : edit_cache/fast
+
+# Special rule for the target install/strip
+install/strip: preinstall
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing the project stripped..."
+ /usr/bin/cmake -DCMAKE_INSTALL_DO_STRIP=1 -P cmake_install.cmake
+.PHONY : install/strip
+
+# Special rule for the target install/strip
+install/strip/fast: install/strip
+
+.PHONY : install/strip/fast
+
+# Special rule for the target test
+test:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running tests..."
+ /usr/bin/ctest --force-new-ctest-process $(ARGS)
+.PHONY : test
+
+# Special rule for the target test
+test/fast: test
+
+.PHONY : test/fast
+
+# Special rule for the target package_source
+package_source:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Run CPack packaging tool for source..."
+ cd /home/martin/XTrackCAD/src/work && /usr/bin/cpack --config ./CPackSourceConfig.cmake /home/martin/XTrackCAD/src/work/CPackSourceConfig.cmake
+.PHONY : package_source
+
+# Special rule for the target package_source
+package_source/fast: package_source
+
+.PHONY : package_source/fast
+
+# Special rule for the target package
+package: preinstall
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Run CPack packaging tool..."
+ cd /home/martin/XTrackCAD/src/work && /usr/bin/cpack --config ./CPackConfig.cmake
+.PHONY : package
+
+# Special rule for the target package
+package/fast: package
+
+.PHONY : package/fast
+
+# Special rule for the target rebuild_cache
+rebuild_cache:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running CMake to regenerate build system..."
+ /usr/bin/cmake -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR)
+.PHONY : rebuild_cache
+
+# Special rule for the target rebuild_cache
+rebuild_cache/fast: rebuild_cache
+
+.PHONY : rebuild_cache/fast
+
+# Special rule for the target install/local
+install/local: preinstall
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing only the local directory..."
+ /usr/bin/cmake -DCMAKE_INSTALL_LOCAL_ONLY=1 -P cmake_install.cmake
+.PHONY : install/local
+
+# Special rule for the target install/local
+install/local/fast: install/local
+
+.PHONY : install/local/fast
+
+# Special rule for the target install
+install: preinstall
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Install the project..."
+ /usr/bin/cmake -P cmake_install.cmake
+.PHONY : install
+
+# Special rule for the target install
+install/fast: preinstall/fast
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Install the project..."
+ /usr/bin/cmake -P cmake_install.cmake
+.PHONY : install/fast
+
+# Special rule for the target list_install_components
+list_install_components:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Available install components are: \"Unspecified\""
+.PHONY : list_install_components
+
+# Special rule for the target list_install_components
+list_install_components/fast: list_install_components
+
+.PHONY : list_install_components/fast
+
+# The main all target
+all: cmake_check_build_system
+ cd /home/martin/XTrackCAD/src/work && $(CMAKE_COMMAND) -E cmake_progress_start /home/martin/XTrackCAD/src/work/CMakeFiles /home/martin/XTrackCAD/src/work/app/cornu/CMakeFiles/progress.marks
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/cornu/all
+ $(CMAKE_COMMAND) -E cmake_progress_start /home/martin/XTrackCAD/src/work/CMakeFiles 0
+.PHONY : all
+
+# The main clean target
+clean:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/cornu/clean
+.PHONY : clean
+
+# The main clean target
+clean/fast: clean
+
+.PHONY : clean/fast
+
+# Prepare targets for installation.
+preinstall: all
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/cornu/preinstall
+.PHONY : preinstall
+
+# Prepare targets for installation.
+preinstall/fast:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/cornu/preinstall
+.PHONY : preinstall/fast
+
+# clear depends
+depend:
+ cd /home/martin/XTrackCAD/src/work && $(CMAKE_COMMAND) -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 1
+.PHONY : depend
+
+# Convenience name for target.
+app/cornu/CMakeFiles/xtrkcad-cornu.dir/rule:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/cornu/CMakeFiles/xtrkcad-cornu.dir/rule
+.PHONY : app/cornu/CMakeFiles/xtrkcad-cornu.dir/rule
+
+# Convenience name for target.
+xtrkcad-cornu: app/cornu/CMakeFiles/xtrkcad-cornu.dir/rule
+
+.PHONY : xtrkcad-cornu
+
+# fast build rule for target.
+xtrkcad-cornu/fast:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/build
+.PHONY : xtrkcad-cornu/fast
+
+bezctx.o: bezctx.c.o
+
+.PHONY : bezctx.o
+
+# target to build an object file
+bezctx.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/bezctx.c.o
+.PHONY : bezctx.c.o
+
+bezctx.i: bezctx.c.i
+
+.PHONY : bezctx.i
+
+# target to preprocess a source file
+bezctx.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/bezctx.c.i
+.PHONY : bezctx.c.i
+
+bezctx.s: bezctx.c.s
+
+.PHONY : bezctx.s
+
+# target to generate assembly for a file
+bezctx.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/bezctx.c.s
+.PHONY : bezctx.c.s
+
+bezctx_xtrkcad.o: bezctx_xtrkcad.c.o
+
+.PHONY : bezctx_xtrkcad.o
+
+# target to build an object file
+bezctx_xtrkcad.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/bezctx_xtrkcad.c.o
+.PHONY : bezctx_xtrkcad.c.o
+
+bezctx_xtrkcad.i: bezctx_xtrkcad.c.i
+
+.PHONY : bezctx_xtrkcad.i
+
+# target to preprocess a source file
+bezctx_xtrkcad.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/bezctx_xtrkcad.c.i
+.PHONY : bezctx_xtrkcad.c.i
+
+bezctx_xtrkcad.s: bezctx_xtrkcad.c.s
+
+.PHONY : bezctx_xtrkcad.s
+
+# target to generate assembly for a file
+bezctx_xtrkcad.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/bezctx_xtrkcad.c.s
+.PHONY : bezctx_xtrkcad.c.s
+
+spiro.o: spiro.c.o
+
+.PHONY : spiro.o
+
+# target to build an object file
+spiro.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/spiro.c.o
+.PHONY : spiro.c.o
+
+spiro.i: spiro.c.i
+
+.PHONY : spiro.i
+
+# target to preprocess a source file
+spiro.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/spiro.c.i
+.PHONY : spiro.c.i
+
+spiro.s: spiro.c.s
+
+.PHONY : spiro.s
+
+# target to generate assembly for a file
+spiro.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/spiro.c.s
+.PHONY : spiro.c.s
+
+spiroentrypoints.o: spiroentrypoints.c.o
+
+.PHONY : spiroentrypoints.o
+
+# target to build an object file
+spiroentrypoints.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/spiroentrypoints.c.o
+.PHONY : spiroentrypoints.c.o
+
+spiroentrypoints.i: spiroentrypoints.c.i
+
+.PHONY : spiroentrypoints.i
+
+# target to preprocess a source file
+spiroentrypoints.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/spiroentrypoints.c.i
+.PHONY : spiroentrypoints.c.i
+
+spiroentrypoints.s: spiroentrypoints.c.s
+
+.PHONY : spiroentrypoints.s
+
+# target to generate assembly for a file
+spiroentrypoints.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/cornu/CMakeFiles/xtrkcad-cornu.dir/build.make app/cornu/CMakeFiles/xtrkcad-cornu.dir/spiroentrypoints.c.s
+.PHONY : spiroentrypoints.c.s
+
+# Help Target
+help:
+ @echo "The following are some of the valid targets for this Makefile:"
+ @echo "... all (the default if no target is provided)"
+ @echo "... clean"
+ @echo "... depend"
+ @echo "... edit_cache"
+ @echo "... install/strip"
+ @echo "... test"
+ @echo "... package_source"
+ @echo "... package"
+ @echo "... rebuild_cache"
+ @echo "... xtrkcad-cornu"
+ @echo "... install/local"
+ @echo "... install"
+ @echo "... list_install_components"
+ @echo "... bezctx.o"
+ @echo "... bezctx.i"
+ @echo "... bezctx.s"
+ @echo "... bezctx_xtrkcad.o"
+ @echo "... bezctx_xtrkcad.i"
+ @echo "... bezctx_xtrkcad.s"
+ @echo "... spiro.o"
+ @echo "... spiro.i"
+ @echo "... spiro.s"
+ @echo "... spiroentrypoints.o"
+ @echo "... spiroentrypoints.i"
+ @echo "... spiroentrypoints.s"
+.PHONY : help
+
+
+
+#=============================================================================
+# Special targets to cleanup operation of make.
+
+# Special rule to run CMake to check the build system integrity.
+# No rule that depends on this can have commands that come from listfiles
+# because they might be regenerated.
+cmake_check_build_system:
+ cd /home/martin/XTrackCAD/src/work && $(CMAKE_COMMAND) -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 0
+.PHONY : cmake_check_build_system
+