summaryrefslogtreecommitdiff
path: root/app/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'app/lib/CMakeLists.txt')
-rw-r--r--app/lib/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/app/lib/CMakeLists.txt b/app/lib/CMakeLists.txt
index 2ec9d2d..3de124e 100644
--- a/app/lib/CMakeLists.txt
+++ b/app/lib/CMakeLists.txt
@@ -15,3 +15,14 @@ INSTALL(FILES
xtrkcad.xtq
DESTINATION ${XTRKCAD_SHARE_INSTALL_DIR}
)
+
+IF(UNIX AND NOT APPLE)
+ INSTALL(FILES
+ xtrkcad.desktop
+ DESTINATION "/usr/share/applications"
+ )
+ INSTALL(FILES
+ xtrkcad.png
+ DESTINATION "/usr/share/pixmaps"
+ )
+ENDIF(UNIX AND NOT APPLE) \ No newline at end of file