summaryrefslogtreecommitdiff
path: root/app/tools/halibut/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'app/tools/halibut/Makefile')
-rw-r--r--app/tools/halibut/Makefile864
1 files changed, 864 insertions, 0 deletions
diff --git a/app/tools/halibut/Makefile b/app/tools/halibut/Makefile
new file mode 100644
index 0000000..03e7fde
--- /dev/null
+++ b/app/tools/halibut/Makefile
@@ -0,0 +1,864 @@
+# CMAKE generated file: DO NOT EDIT!
+# Generated by "Unix Makefiles" Generator, CMake Version 3.6
+
+# Default target executed when no arguments are given to make.
+default_target: all
+
+.PHONY : default_target
+
+# Allow only one "make -f Makefile2" at a time, but pass parallelism.
+.NOTPARALLEL:
+
+
+#=============================================================================
+# Special targets provided by cmake.
+
+# Disable implicit rules so canonical targets will work.
+.SUFFIXES:
+
+
+# Remove some rules from gmake that .SUFFIXES does not remove.
+SUFFIXES =
+
+.SUFFIXES: .hpux_make_needs_suffix_list
+
+
+# Suppress display of executed commands.
+$(VERBOSE).SILENT:
+
+
+# A target that is always out of date.
+cmake_force:
+
+.PHONY : cmake_force
+
+#=============================================================================
+# Set environment variables for the build.
+
+# The shell in which to execute make rules.
+SHELL = /bin/sh
+
+# The CMake executable.
+CMAKE_COMMAND = /usr/bin/cmake
+
+# The command to remove a file.
+RM = /usr/bin/cmake -E remove -f
+
+# Escaping for special characters.
+EQUALS = =
+
+# The top-level source directory on which CMake was run.
+CMAKE_SOURCE_DIR = /home/martin/XTrackCAD/src/work
+
+# The top-level build directory on which CMake was run.
+CMAKE_BINARY_DIR = /home/martin/XTrackCAD/src/work
+
+#=============================================================================
+# Targets provided globally by CMake.
+
+# Special rule for the target edit_cache
+edit_cache:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running CMake cache editor..."
+ /usr/bin/ccmake -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR)
+.PHONY : edit_cache
+
+# Special rule for the target edit_cache
+edit_cache/fast: edit_cache
+
+.PHONY : edit_cache/fast
+
+# Special rule for the target install/strip
+install/strip: preinstall
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing the project stripped..."
+ /usr/bin/cmake -DCMAKE_INSTALL_DO_STRIP=1 -P cmake_install.cmake
+.PHONY : install/strip
+
+# Special rule for the target install/strip
+install/strip/fast: install/strip
+
+.PHONY : install/strip/fast
+
+# Special rule for the target test
+test:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running tests..."
+ /usr/bin/ctest --force-new-ctest-process $(ARGS)
+.PHONY : test
+
+# Special rule for the target test
+test/fast: test
+
+.PHONY : test/fast
+
+# Special rule for the target package
+package: preinstall
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Run CPack packaging tool..."
+ cd /home/martin/XTrackCAD/src/work && /usr/bin/cpack --config ./CPackConfig.cmake
+.PHONY : package
+
+# Special rule for the target package
+package/fast: package
+
+.PHONY : package/fast
+
+# Special rule for the target rebuild_cache
+rebuild_cache:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Running CMake to regenerate build system..."
+ /usr/bin/cmake -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR)
+.PHONY : rebuild_cache
+
+# Special rule for the target rebuild_cache
+rebuild_cache/fast: rebuild_cache
+
+.PHONY : rebuild_cache/fast
+
+# Special rule for the target package_source
+package_source:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Run CPack packaging tool for source..."
+ cd /home/martin/XTrackCAD/src/work && /usr/bin/cpack --config ./CPackSourceConfig.cmake /home/martin/XTrackCAD/src/work/CPackSourceConfig.cmake
+.PHONY : package_source
+
+# Special rule for the target package_source
+package_source/fast: package_source
+
+.PHONY : package_source/fast
+
+# Special rule for the target install/local
+install/local: preinstall
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Installing only the local directory..."
+ /usr/bin/cmake -DCMAKE_INSTALL_LOCAL_ONLY=1 -P cmake_install.cmake
+.PHONY : install/local
+
+# Special rule for the target install/local
+install/local/fast: install/local
+
+.PHONY : install/local/fast
+
+# Special rule for the target install
+install: preinstall
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Install the project..."
+ /usr/bin/cmake -P cmake_install.cmake
+.PHONY : install
+
+# Special rule for the target install
+install/fast: preinstall/fast
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Install the project..."
+ /usr/bin/cmake -P cmake_install.cmake
+.PHONY : install/fast
+
+# Special rule for the target list_install_components
+list_install_components:
+ @$(CMAKE_COMMAND) -E cmake_echo_color --switch=$(COLOR) --cyan "Available install components are: \"Unspecified\""
+.PHONY : list_install_components
+
+# Special rule for the target list_install_components
+list_install_components/fast: list_install_components
+
+.PHONY : list_install_components/fast
+
+# The main all target
+all: cmake_check_build_system
+ cd /home/martin/XTrackCAD/src/work && $(CMAKE_COMMAND) -E cmake_progress_start /home/martin/XTrackCAD/src/work/CMakeFiles /home/martin/XTrackCAD/src/work/app/tools/halibut/CMakeFiles/progress.marks
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/tools/halibut/all
+ $(CMAKE_COMMAND) -E cmake_progress_start /home/martin/XTrackCAD/src/work/CMakeFiles 0
+.PHONY : all
+
+# The main clean target
+clean:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/tools/halibut/clean
+.PHONY : clean
+
+# The main clean target
+clean/fast: clean
+
+.PHONY : clean/fast
+
+# Prepare targets for installation.
+preinstall: all
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/tools/halibut/preinstall
+.PHONY : preinstall
+
+# Prepare targets for installation.
+preinstall/fast:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/tools/halibut/preinstall
+.PHONY : preinstall/fast
+
+# clear depends
+depend:
+ cd /home/martin/XTrackCAD/src/work && $(CMAKE_COMMAND) -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 1
+.PHONY : depend
+
+# Convenience name for target.
+app/tools/halibut/CMakeFiles/halibut.dir/rule:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f CMakeFiles/Makefile2 app/tools/halibut/CMakeFiles/halibut.dir/rule
+.PHONY : app/tools/halibut/CMakeFiles/halibut.dir/rule
+
+# Convenience name for target.
+halibut: app/tools/halibut/CMakeFiles/halibut.dir/rule
+
+.PHONY : halibut
+
+# fast build rule for target.
+halibut/fast:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/build
+.PHONY : halibut/fast
+
+biblio.o: biblio.c.o
+
+.PHONY : biblio.o
+
+# target to build an object file
+biblio.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/biblio.c.o
+.PHONY : biblio.c.o
+
+biblio.i: biblio.c.i
+
+.PHONY : biblio.i
+
+# target to preprocess a source file
+biblio.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/biblio.c.i
+.PHONY : biblio.c.i
+
+biblio.s: biblio.c.s
+
+.PHONY : biblio.s
+
+# target to generate assembly for a file
+biblio.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/biblio.c.s
+.PHONY : biblio.c.s
+
+bk_html.o: bk_html.c.o
+
+.PHONY : bk_html.o
+
+# target to build an object file
+bk_html.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/bk_html.c.o
+.PHONY : bk_html.c.o
+
+bk_html.i: bk_html.c.i
+
+.PHONY : bk_html.i
+
+# target to preprocess a source file
+bk_html.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/bk_html.c.i
+.PHONY : bk_html.c.i
+
+bk_html.s: bk_html.c.s
+
+.PHONY : bk_html.s
+
+# target to generate assembly for a file
+bk_html.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/bk_html.c.s
+.PHONY : bk_html.c.s
+
+bk_paper.o: bk_paper.c.o
+
+.PHONY : bk_paper.o
+
+# target to build an object file
+bk_paper.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/bk_paper.c.o
+.PHONY : bk_paper.c.o
+
+bk_paper.i: bk_paper.c.i
+
+.PHONY : bk_paper.i
+
+# target to preprocess a source file
+bk_paper.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/bk_paper.c.i
+.PHONY : bk_paper.c.i
+
+bk_paper.s: bk_paper.c.s
+
+.PHONY : bk_paper.s
+
+# target to generate assembly for a file
+bk_paper.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/bk_paper.c.s
+.PHONY : bk_paper.c.s
+
+contents.o: contents.c.o
+
+.PHONY : contents.o
+
+# target to build an object file
+contents.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/contents.c.o
+.PHONY : contents.c.o
+
+contents.i: contents.c.i
+
+.PHONY : contents.i
+
+# target to preprocess a source file
+contents.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/contents.c.i
+.PHONY : contents.c.i
+
+contents.s: contents.c.s
+
+.PHONY : contents.s
+
+# target to generate assembly for a file
+contents.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/contents.c.s
+.PHONY : contents.c.s
+
+deflate.o: deflate.c.o
+
+.PHONY : deflate.o
+
+# target to build an object file
+deflate.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/deflate.c.o
+.PHONY : deflate.c.o
+
+deflate.i: deflate.c.i
+
+.PHONY : deflate.i
+
+# target to preprocess a source file
+deflate.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/deflate.c.i
+.PHONY : deflate.c.i
+
+deflate.s: deflate.c.s
+
+.PHONY : deflate.s
+
+# target to generate assembly for a file
+deflate.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/deflate.c.s
+.PHONY : deflate.c.s
+
+error.o: error.c.o
+
+.PHONY : error.o
+
+# target to build an object file
+error.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/error.c.o
+.PHONY : error.c.o
+
+error.i: error.c.i
+
+.PHONY : error.i
+
+# target to preprocess a source file
+error.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/error.c.i
+.PHONY : error.c.i
+
+error.s: error.c.s
+
+.PHONY : error.s
+
+# target to generate assembly for a file
+error.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/error.c.s
+.PHONY : error.c.s
+
+help.o: help.c.o
+
+.PHONY : help.o
+
+# target to build an object file
+help.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/help.c.o
+.PHONY : help.c.o
+
+help.i: help.c.i
+
+.PHONY : help.i
+
+# target to preprocess a source file
+help.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/help.c.i
+.PHONY : help.c.i
+
+help.s: help.c.s
+
+.PHONY : help.s
+
+# target to generate assembly for a file
+help.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/help.c.s
+.PHONY : help.c.s
+
+in_afm.o: in_afm.c.o
+
+.PHONY : in_afm.o
+
+# target to build an object file
+in_afm.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/in_afm.c.o
+.PHONY : in_afm.c.o
+
+in_afm.i: in_afm.c.i
+
+.PHONY : in_afm.i
+
+# target to preprocess a source file
+in_afm.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/in_afm.c.i
+.PHONY : in_afm.c.i
+
+in_afm.s: in_afm.c.s
+
+.PHONY : in_afm.s
+
+# target to generate assembly for a file
+in_afm.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/in_afm.c.s
+.PHONY : in_afm.c.s
+
+in_pf.o: in_pf.c.o
+
+.PHONY : in_pf.o
+
+# target to build an object file
+in_pf.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/in_pf.c.o
+.PHONY : in_pf.c.o
+
+in_pf.i: in_pf.c.i
+
+.PHONY : in_pf.i
+
+# target to preprocess a source file
+in_pf.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/in_pf.c.i
+.PHONY : in_pf.c.i
+
+in_pf.s: in_pf.c.s
+
+.PHONY : in_pf.s
+
+# target to generate assembly for a file
+in_pf.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/in_pf.c.s
+.PHONY : in_pf.c.s
+
+index.o: index.c.o
+
+.PHONY : index.o
+
+# target to build an object file
+index.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/index.c.o
+.PHONY : index.c.o
+
+index.i: index.c.i
+
+.PHONY : index.i
+
+# target to preprocess a source file
+index.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/index.c.i
+.PHONY : index.c.i
+
+index.s: index.c.s
+
+.PHONY : index.s
+
+# target to generate assembly for a file
+index.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/index.c.s
+.PHONY : index.c.s
+
+input.o: input.c.o
+
+.PHONY : input.o
+
+# target to build an object file
+input.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/input.c.o
+.PHONY : input.c.o
+
+input.i: input.c.i
+
+.PHONY : input.i
+
+# target to preprocess a source file
+input.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/input.c.i
+.PHONY : input.c.i
+
+input.s: input.c.s
+
+.PHONY : input.s
+
+# target to generate assembly for a file
+input.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/input.c.s
+.PHONY : input.c.s
+
+keywords.o: keywords.c.o
+
+.PHONY : keywords.o
+
+# target to build an object file
+keywords.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/keywords.c.o
+.PHONY : keywords.c.o
+
+keywords.i: keywords.c.i
+
+.PHONY : keywords.i
+
+# target to preprocess a source file
+keywords.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/keywords.c.i
+.PHONY : keywords.c.i
+
+keywords.s: keywords.c.s
+
+.PHONY : keywords.s
+
+# target to generate assembly for a file
+keywords.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/keywords.c.s
+.PHONY : keywords.c.s
+
+licence.o: licence.c.o
+
+.PHONY : licence.o
+
+# target to build an object file
+licence.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/licence.c.o
+.PHONY : licence.c.o
+
+licence.i: licence.c.i
+
+.PHONY : licence.i
+
+# target to preprocess a source file
+licence.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/licence.c.i
+.PHONY : licence.c.i
+
+licence.s: licence.c.s
+
+.PHONY : licence.s
+
+# target to generate assembly for a file
+licence.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/licence.c.s
+.PHONY : licence.c.s
+
+main.o: main.c.o
+
+.PHONY : main.o
+
+# target to build an object file
+main.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/main.c.o
+.PHONY : main.c.o
+
+main.i: main.c.i
+
+.PHONY : main.i
+
+# target to preprocess a source file
+main.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/main.c.i
+.PHONY : main.c.i
+
+main.s: main.c.s
+
+.PHONY : main.s
+
+# target to generate assembly for a file
+main.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/main.c.s
+.PHONY : main.c.s
+
+malloc.o: malloc.c.o
+
+.PHONY : malloc.o
+
+# target to build an object file
+malloc.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/malloc.c.o
+.PHONY : malloc.c.o
+
+malloc.i: malloc.c.i
+
+.PHONY : malloc.i
+
+# target to preprocess a source file
+malloc.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/malloc.c.i
+.PHONY : malloc.c.i
+
+malloc.s: malloc.c.s
+
+.PHONY : malloc.s
+
+# target to generate assembly for a file
+malloc.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/malloc.c.s
+.PHONY : malloc.c.s
+
+misc.o: misc.c.o
+
+.PHONY : misc.o
+
+# target to build an object file
+misc.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/misc.c.o
+.PHONY : misc.c.o
+
+misc.i: misc.c.i
+
+.PHONY : misc.i
+
+# target to preprocess a source file
+misc.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/misc.c.i
+.PHONY : misc.c.i
+
+misc.s: misc.c.s
+
+.PHONY : misc.s
+
+# target to generate assembly for a file
+misc.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/misc.c.s
+.PHONY : misc.c.s
+
+psdata.o: psdata.c.o
+
+.PHONY : psdata.o
+
+# target to build an object file
+psdata.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/psdata.c.o
+.PHONY : psdata.c.o
+
+psdata.i: psdata.c.i
+
+.PHONY : psdata.i
+
+# target to preprocess a source file
+psdata.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/psdata.c.i
+.PHONY : psdata.c.i
+
+psdata.s: psdata.c.s
+
+.PHONY : psdata.s
+
+# target to generate assembly for a file
+psdata.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/psdata.c.s
+.PHONY : psdata.c.s
+
+tree234.o: tree234.c.o
+
+.PHONY : tree234.o
+
+# target to build an object file
+tree234.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/tree234.c.o
+.PHONY : tree234.c.o
+
+tree234.i: tree234.c.i
+
+.PHONY : tree234.i
+
+# target to preprocess a source file
+tree234.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/tree234.c.i
+.PHONY : tree234.c.i
+
+tree234.s: tree234.c.s
+
+.PHONY : tree234.s
+
+# target to generate assembly for a file
+tree234.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/tree234.c.s
+.PHONY : tree234.c.s
+
+ustring.o: ustring.c.o
+
+.PHONY : ustring.o
+
+# target to build an object file
+ustring.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/ustring.c.o
+.PHONY : ustring.c.o
+
+ustring.i: ustring.c.i
+
+.PHONY : ustring.i
+
+# target to preprocess a source file
+ustring.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/ustring.c.i
+.PHONY : ustring.c.i
+
+ustring.s: ustring.c.s
+
+.PHONY : ustring.s
+
+# target to generate assembly for a file
+ustring.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/ustring.c.s
+.PHONY : ustring.c.s
+
+version.o: version.c.o
+
+.PHONY : version.o
+
+# target to build an object file
+version.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/version.c.o
+.PHONY : version.c.o
+
+version.i: version.c.i
+
+.PHONY : version.i
+
+# target to preprocess a source file
+version.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/version.c.i
+.PHONY : version.c.i
+
+version.s: version.c.s
+
+.PHONY : version.s
+
+# target to generate assembly for a file
+version.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/version.c.s
+.PHONY : version.c.s
+
+wcwidth.o: wcwidth.c.o
+
+.PHONY : wcwidth.o
+
+# target to build an object file
+wcwidth.c.o:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/wcwidth.c.o
+.PHONY : wcwidth.c.o
+
+wcwidth.i: wcwidth.c.i
+
+.PHONY : wcwidth.i
+
+# target to preprocess a source file
+wcwidth.c.i:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/wcwidth.c.i
+.PHONY : wcwidth.c.i
+
+wcwidth.s: wcwidth.c.s
+
+.PHONY : wcwidth.s
+
+# target to generate assembly for a file
+wcwidth.c.s:
+ cd /home/martin/XTrackCAD/src/work && $(MAKE) -f app/tools/halibut/CMakeFiles/halibut.dir/build.make app/tools/halibut/CMakeFiles/halibut.dir/wcwidth.c.s
+.PHONY : wcwidth.c.s
+
+# Help Target
+help:
+ @echo "The following are some of the valid targets for this Makefile:"
+ @echo "... all (the default if no target is provided)"
+ @echo "... clean"
+ @echo "... depend"
+ @echo "... edit_cache"
+ @echo "... install/strip"
+ @echo "... test"
+ @echo "... package"
+ @echo "... rebuild_cache"
+ @echo "... package_source"
+ @echo "... halibut"
+ @echo "... install/local"
+ @echo "... install"
+ @echo "... list_install_components"
+ @echo "... biblio.o"
+ @echo "... biblio.i"
+ @echo "... biblio.s"
+ @echo "... bk_html.o"
+ @echo "... bk_html.i"
+ @echo "... bk_html.s"
+ @echo "... bk_paper.o"
+ @echo "... bk_paper.i"
+ @echo "... bk_paper.s"
+ @echo "... contents.o"
+ @echo "... contents.i"
+ @echo "... contents.s"
+ @echo "... deflate.o"
+ @echo "... deflate.i"
+ @echo "... deflate.s"
+ @echo "... error.o"
+ @echo "... error.i"
+ @echo "... error.s"
+ @echo "... help.o"
+ @echo "... help.i"
+ @echo "... help.s"
+ @echo "... in_afm.o"
+ @echo "... in_afm.i"
+ @echo "... in_afm.s"
+ @echo "... in_pf.o"
+ @echo "... in_pf.i"
+ @echo "... in_pf.s"
+ @echo "... index.o"
+ @echo "... index.i"
+ @echo "... index.s"
+ @echo "... input.o"
+ @echo "... input.i"
+ @echo "... input.s"
+ @echo "... keywords.o"
+ @echo "... keywords.i"
+ @echo "... keywords.s"
+ @echo "... licence.o"
+ @echo "... licence.i"
+ @echo "... licence.s"
+ @echo "... main.o"
+ @echo "... main.i"
+ @echo "... main.s"
+ @echo "... malloc.o"
+ @echo "... malloc.i"
+ @echo "... malloc.s"
+ @echo "... misc.o"
+ @echo "... misc.i"
+ @echo "... misc.s"
+ @echo "... psdata.o"
+ @echo "... psdata.i"
+ @echo "... psdata.s"
+ @echo "... tree234.o"
+ @echo "... tree234.i"
+ @echo "... tree234.s"
+ @echo "... ustring.o"
+ @echo "... ustring.i"
+ @echo "... ustring.s"
+ @echo "... version.o"
+ @echo "... version.i"
+ @echo "... version.s"
+ @echo "... wcwidth.o"
+ @echo "... wcwidth.i"
+ @echo "... wcwidth.s"
+.PHONY : help
+
+
+
+#=============================================================================
+# Special targets to cleanup operation of make.
+
+# Special rule to run CMake to check the build system integrity.
+# No rule that depends on this can have commands that come from listfiles
+# because they might be regenerated.
+cmake_check_build_system:
+ cd /home/martin/XTrackCAD/src/work && $(CMAKE_COMMAND) -H$(CMAKE_SOURCE_DIR) -B$(CMAKE_BINARY_DIR) --check-build-system CMakeFiles/Makefile.cmake 0
+.PHONY : cmake_check_build_system
+