Description: Change help html directory to the installation specific
Author: Jörg Frings-Fürst
Forwarded: not-needed
Last-Update: 2017-01-02
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
Index: trunk/app/wlib/gtklib/gtkhelp.c
===================================================================
--- trunk.orig/app/wlib/gtklib/gtkhelp.c
+++ trunk/app/wlib/gtklib/gtkhelp.c
@@ -677,8 +677,12 @@ EXPORT void wHelp( const char * topic )
directory = malloc( BUFSIZ );
assert( directory != NULL );
- sprintf( directory, "%s/html/", wGetAppLibDir());
-
+/* sprintf( directory, "%s/html/", wGetAppLibDir());*/
+/*
+ * Change path for debian installation
+ *
+ */
+ sprintf( directory, "%s/html/", "/usr/share/doc/xtrkcad-common");
wHelpWindow = CreateHelpWindow();
/* load the default content */
load_into_view ("index.html", MAIN_VIEW);