summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2014-09-10 10:44:39 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2014-09-10 10:44:39 +0200
commitfe6fa5c5a90206e28c8edd2c4dec32ccaa84c709 (patch)
treed5b1ac5fb4d9816da66fbb8b73e4f90622c06c84 /debian/rules
parenta879b4e708b3e46c9697ba6581687eeb5b02a320 (diff)
edit man pages
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules35
1 files changed, 15 insertions, 20 deletions
diff --git a/debian/rules b/debian/rules
index 0f3d8ec..92d1baa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
# hardening
-#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed -Wl,--no-undefined
@@ -32,7 +32,7 @@ override_dh_auto_clean:
rm -f $(CURDIR)/imdi/imdi_k.c
rm -rf $(CURDIR)/debian/tmp/*
[ ! -d $(CURDIR)/debian/tmp ] || rmdir --ignore-fail-on-non-empty $(CURDIR)/debian/tmp
- dh_clean
+ dh_auto_clean
override_dh_auto_install:
jam $(JAMCMDLINE) dirs
@@ -40,38 +40,33 @@ override_dh_auto_install:
rm $(CURDIR)/debian/tmp/usr/bin/License.txt
override_dh_installdocs:
- dh_installdocs --link-doc=argyll-doc
+# mkdir -p $(CURDIR)/doc/html
+# mv -f $(CURDIR)/doc/* $(CURDIR)/doc/html
+ dh_installdocs -A --link-doc=argyll-doc
+ mkdir -p $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/html
+ mv -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/*.html $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/html/
+ mv -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/*.jpg $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/html/
+ mv -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/SG_*.txt $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/html/
+ mv -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/*.gif $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/html/
+ mv -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/*.xls $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/html/
+ mv -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/*.zip $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/html/
+ mv -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/ccmxs $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/html/
rm -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/License.txt
rm -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/License2.txt
rm -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/License3.txt
-# rm $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/License4.txt
rm -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/DocLicense.txt
-
+ rm -f $(CURDIR)/debian/argyll-doc/usr/share/doc/argyll-doc/afiles
override_dh_installchangelogs:
dh_installchangelogs log.txt
-#LIBICC_VERSION=$(shell awk -F= '/^LIBICC_VERSION=/ { print $$2 }' icc/Makefile.am)
-#ARGYLL_VERSION=$(shell dpkg-parsechangelog | awk '/^Version:/ { print $$2 }')
-
-#override_dh_gencontrol:
-## dh_gencontrol -plibicc2 -- -v$(LIBICC_VERSION)+argyll$(ARGYLL_VERSION)
-## dh_gencontrol -plibicc-dev -- -v$(LIBICC_VERSION)+argyll$(ARGYLL_VERSION)
-# dh_gencontrol --remaining-packages
-
-#build: firmware-package-builder/spyder2.tar.gz
-
-#firmware-package-builder/%.tar.gz: firmware-package-builder/argyll-firmware-%
-# chmod +x $</debian/rules
-# tar cfCz $@ firmware-package-builder $(notdir $<)
-
override_dh_strip:
dh_strip --dbg-package=argyll-dbg
build-manpages:
+ help2man -N --no-discard-stderr --name="Apply device calibration to an ICC profile." debian/tmp/usr/bin/applycal > debian/man/applycal.1
help2man -N --no-discard-stderr --name="Dump an ICC file in human readable form." debian/tmp/usr/bin/iccdump > debian/man/iccdump.1
help2man -N --no-discard-stderr --name="Translate colors through an ICC profile." debian/tmp/usr/bin/icclu > debian/man/icclu.1
- help2man -N --no-discard-stderr --name="Apply device calibration to an ICC profile." debian/tmp/usr/bin/applycal > debian/man/applycal.1
help2man -N --no-discard-stderr --name="Average or merge values in .ti3 like files." debian/tmp/usr/bin/average > debian/man/average.1
help2man -N --no-discard-stderr --name="Convert Colorblind raw device profile data to Argyll data." debian/tmp/usr/bin/cb2ti3 > debian/man/cb2ti3.1
help2man -N --no-discard-stderr --name="Color Correct a TIFF file using any sequence of ICC profiles or Calibrations." debian/tmp/usr/bin/cctiff > debian/man/cctiff.1