summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 85ab4d3..6f743b7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,8 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+include /usr/share/dpkg/pkg-info.mk
+
export DH_OPTIONS
# hardening
@@ -11,8 +13,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
NO_PROC=$(shell cat /proc/cpuinfo | grep processor | wc -l)
JAMCMDLINE = -q -fJambase -j$(NO_PROC) -sPREFIX=/usr -sDESTDIR=$(CURDIR)/debian/tmp -sREFSUBDIR=share/color/argyll/ref
-CHDATE=$(shell dpkg-parsechangelog -S Date)
-CRDATE=$(shell LC_ALL=C date --utc -d "$(CHDATE)" "+%a %b %d %T %Y")
+CRDATE=$(shell LC_ALL=C date --utc --date='@$(SOURCE_DATE_EPOCH)' "+%a %b %d %T %Y")
%:
dh $@