summaryrefslogtreecommitdiff
path: root/lib/icap/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-21 14:51:17 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-11-21 14:51:17 +0100
commitbb9bc9051629c3319c56785c2f4ae0e605d76329 (patch)
treeec393eb145e5a7d43909bdfc43cdeaa28c4e434a /lib/icap/Makefile.am
Initial import of bitz-server version 0.1.6-1
Diffstat (limited to 'lib/icap/Makefile.am')
-rw-r--r--lib/icap/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/icap/Makefile.am b/lib/icap/Makefile.am
new file mode 100644
index 0000000..02d8bb4
--- /dev/null
+++ b/lib/icap/Makefile.am
@@ -0,0 +1,24 @@
+## [icap-library] lib/icap/
+AM_CPPFLAGS = -I$(top_srcdir)/lib
+libicapincludedir = $(includedir)/icap
+
+lib_LTLIBRARIES = libicap.la
+libicap_la_LIBADD = $(top_builddir)/lib/socket/libsocket.la
+libicap_la_LDFLAGS = -version-info @ICAP_LT_VERSION@ -no-undefined
+libicap_la_SOURCES = \
+ header.cpp \
+ request_header.cpp \
+ response_header.cpp \
+ request.cpp \
+ response.cpp \
+ util.cpp
+
+libicapinclude_HEADERS = \
+ common.h \
+ header.h \
+ request_header.h \
+ response_header.h \
+ request.h \
+ response.h \
+ util.h
+