summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d972716..199e35a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.68])
-AC_INIT([bitz-server], [1.0.2], [https://github.com/uditha-atukorala/bitz-server/issues])
+AC_INIT([bitz-server], [2.0.0], [https://github.com/uditha-atukorala/bitz-server/issues])
AC_CONFIG_AUX_DIR([aux-build])
AC_CONFIG_MACRO_DIR([aux-build/m4])
AC_CONFIG_HEADERS([include/config.h])
@@ -49,6 +49,7 @@ AC_PROG_LIBTOOL
# Language
AC_LANG(C++)
+AX_CXX_COMPILE_STDCXX_11()
# Options
AC_ARG_WITH([config],
@@ -75,9 +76,6 @@ PKG_PROG_PKG_CONFIG
PKG_CHECK_MODULES([libconfig], [libconfig++ >= 1.4],,
AC_MSG_ERROR([libconfig++ 1.4 or newer not found.])
)
-PKG_CHECK_MODULES([log4cpp], [log4cpp >= 1.0],,
- AC_MSG_ERROR([log4cpp 1.0 or newer not found.])
-)
PKG_CHECK_MODULES([psocksxx], [psocksxx >= 0.0.6],,
AC_MSG_ERROR([psocksxx 0.0.6 or newer not found.])
)