summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-06-04 23:20:38 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-06-04 23:20:38 +0200
commit7869df43d6fd88ece4de7d0672e4e590767cf1fe (patch)
tree46b57880fda6a59f423eec136252cd96f5819d35 /Makefile.am
parent819a9ab222da57d6064a7cc9ad3e2c9ff0ef2f82 (diff)
Imported Upstream version 1.0upstream/1.0upstream
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 15 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 9558f2d..00742e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,11 @@
#
# Makefile.am
#
-# Copyright (c) 2009-2013 EPIPE Communications. All rights reserved.
+# Copyright (c) 2009-2016 Janne Snabb. All rights reserved.
#
-# This software is licensed under the terms and conditions of the FreeBSD
-# License which is also known as the Simplified BSD License. You should have
-# received a copy of that license along with this software.
+# This software is licensed under the terms and conditions of the
+# Simplified BSD License. You should have received a copy of that
+# license along with this software.
#
sbin_PROGRAMS = downtimed
@@ -14,15 +14,19 @@ downtimed_SOURCES = downtimed.c downtimedb.c downtimedb.h
downtimes_SOURCES = downtimes.c downtimedb.c downtimedb.h
dist_man_MANS = downtimed.8 downtimes.1
-EXTRA_DIST = README LICENSE INSTALL NEWS startup-scripts
+EXTRA_DIST = README.md LICENSE INSTALL NEWS startup-scripts
-#install-exec-hook:
-# ln -f $(DESTDIR)$(bindir)/downtimes$(EXEEXT) \
-# $(DESTDIR)$(bindir)/downtime$(EXEEXT)
+install-exec-hook:
+ ln -f $(DESTDIR)$(bindir)/downtimes$(EXEEXT) \
+ $(DESTDIR)$(bindir)/downtime$(EXEEXT)
-#install-data-hook:
-# ln -f $(DESTDIR)$(mandir)/man1/downtimes.1 \
-# $(DESTDIR)$(mandir)/man1/downtime.1
+install-data-hook:
+ ln -f $(DESTDIR)$(mandir)/man1/downtimes.1 \
+ $(DESTDIR)$(mandir)/man1/downtime.1
+
+uninstall-hook:
+ rm -f $(DESTDIR)$(bindir)/downtime$(EXEEXT)
+ rm -f $(DESTDIR)$(mandir)/man1/downtime.1
.1.pdf:
pdfroff --no-toc -man -mpdfmark $< > $@