summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2014-08-08 14:02:36 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2014-08-08 14:02:36 +0200
commitf76d1cde0a33131bf187d00385b8cfde7f45bbc6 (patch)
tree8d875746196812f86362a5caac846d38c5483ea3 /debian/rules
Initial import of fast-cpp-csv-parser version 0.0+git20140808~0a259084edad-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ae186f8
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+PKD = $(abspath $(dir $(MAKEFILE_LIST)))
+PKG = $(word 2,$(shell dpkg-parsechangelog -l$(PKD)/changelog | grep ^Source))
+VER = $(shell dpkg-parsechangelog -l$(PKD)/changelog -SVersion | cut -d- -f1)
+
+
+%:
+ dh $@
+
+override_dh_auto_build:
+
+get-orig-source: $(info I: $(PKG)_$(VER))
+ cd ${CURDIR}
+ wget https://fast-cpp-csv-parser.googlecode.com/git/csv.h -O csv.h
+ tar -cJf ../$(PKG)_$(VER).orig.tar.xz *.h