summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessandro Ghedini <al3xbio@gmail.com>2012-01-24 09:42:25 +0100
committerAlessandro Ghedini <al3xbio@gmail.com>2012-01-24 09:42:25 +0100
commit21c8b0c749be00fff27e41e4c2d677dd7d320fa0 (patch)
treee439b4de4a50a1bb656762f6e7a79a39431dd526 /CMakeLists.txt
parent60560a030fda3c539ff9dc1563b9926414a193da (diff)
Imported Upstream version 0.4.1upstream/0.4.1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1327bf..9e06bc7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,7 @@ pkg_check_modules(XTST REQUIRED xtst)
pkg_check_modules(GMENU3 libgnome-menu-3.0)
find_library(M_LIB m)
+find_library(GTHREAD_LIB gthread-2.0)
set(CFLAGS
${GIO_CFLAGS}
@@ -81,9 +82,8 @@ endif (${GMENU3_FOUND})
if (${INDICATOR_FOUND})
LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
endif (${INDICATOR_FOUND})
-
if (${INDICATOR3_FOUND})
- LIST(APPEND CFLAGS -DHAVE_APPINDICATOR3)
+ LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
endif (${INDICATOR3_FOUND})
add_definitions(${CFLAGS})
@@ -105,6 +105,7 @@ set(LIBS
${WNCK_LIBRARIES}
${BAMF_LIBRARIES}
${M_LIB}
+ ${GTHREAD_LIB}
)
link_libraries(${LIBS})