summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessandro Ghedini <al3xbio@gmail.com>2012-01-21 19:07:09 +0100
committerAlessandro Ghedini <al3xbio@gmail.com>2012-01-21 19:07:09 +0100
commit60560a030fda3c539ff9dc1563b9926414a193da (patch)
tree77590b395685a8d48d3615e45629a1610d08c071 /src/CMakeLists.txt
parentd6b2677825cbb423e2099563c16321c3e23d7899 (diff)
Imported Upstream version 0.4.0upstream/0.4.0
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 23b9474..b809c48 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -9,6 +9,10 @@ if (${INDICATOR_FOUND})
SET(DEFINES --define HAVE_APPINDICATOR)
endif(${INDICATOR_FOUND})
+if (${GTK3_FOUND})
+ SET(DEFINES --define HAVE_GTK_3)
+endif(${GTK3_FOUND})
+
if (${GMENU3_FOUND})
LIST(APPEND DEFINES --define HAVE_GMENU_3)
endif (${GMENU3_FOUND})
@@ -39,7 +43,7 @@ install(
# install credits
install(
FILES
- ${CMAKE_SOURCE_DIR}/README
+ ${CMAKE_SOURCE_DIR}/README.md
DESTINATION
${CMAKE_INSTALL_PREFIX}/share/doc/gnome-pie
)
@@ -63,11 +67,18 @@ install(
${CMAKE_INSTALL_PREFIX}/share/gnome-pie
)
+# install UI files
+install(
+ DIRECTORY
+ ${CMAKE_SOURCE_DIR}/resources/ui
+ DESTINATION
+ ${CMAKE_INSTALL_PREFIX}/share/gnome-pie
+)
+
# install icons
install(
FILES
${CMAKE_SOURCE_DIR}/resources/gnome-pie.svg
- ${CMAKE_SOURCE_DIR}/resources/gnome-pie-indicator.svg
DESTINATION
${CMAKE_INSTALL_PREFIX}/share/icons/hicolor/scalable/apps
)