summaryrefslogtreecommitdiff
path: root/debian/patches/0700-ayatana-appindicator.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0700-ayatana-appindicator.patch')
-rw-r--r--debian/patches/0700-ayatana-appindicator.patch77
1 files changed, 77 insertions, 0 deletions
diff --git a/debian/patches/0700-ayatana-appindicator.patch b/debian/patches/0700-ayatana-appindicator.patch
new file mode 100644
index 0000000..d8a9905
--- /dev/null
+++ b/debian/patches/0700-ayatana-appindicator.patch
@@ -0,0 +1,77 @@
+Description: Switch to Ayatana AppIndicator
+Author: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=907551
+Forwarded: not-needed
+Last-Update: 2018-09-07
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,7 +26,7 @@
+ find_package(PkgConfig)
+
+ pkg_check_modules(GTK3 REQUIRED gtk+-3.0)
+-pkg_check_modules(INDICATOR3 appindicator3-0.1)
++pkg_check_modules(INDICATOR3 ayatana-appindicator3-0.1)
+ pkg_check_modules(WNCK REQUIRED libwnck-3.0)
+ pkg_check_modules(BAMF libbamf3)
+ pkg_check_modules(GIO REQUIRED gio-unix-2.0)
+@@ -75,11 +75,7 @@
+ pkg_check_modules(GMENU REQUIRED libgnome-menu)
+ endif (${GMENU3_FOUND})
+
+-# notify application of presence of libappindicator
+-if (${INDICATOR_FOUND})
+- LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
+- LIST(APPEND VALA_DEFINES --define HAVE_APPINDICATOR)
+-endif (${INDICATOR_FOUND})
++# notify application of presence of libayatana-appindicator
+ if (${INDICATOR3_FOUND})
+ LIST(APPEND CFLAGS -DHAVE_APPINDICATOR)
+ LIST(APPEND VALA_DEFINES --define HAVE_APPINDICATOR)
+@@ -97,7 +93,6 @@
+ ${GTK3_LIBRARIES}
+ ${CAIRO_LIBRARIES}
+ ${GEE_LIBRARIES}
+- ${INDICATOR_LIBRARIES}
+ ${INDICATOR3_LIBRARIES}
+ ${XML_LIBRARIES}
+ ${XTST_LIBRARIES}
+@@ -117,7 +112,6 @@
+ ${GTK3_LIBRARY_DIRS}
+ ${CAIRO_LIBRARY_DIRS}
+ ${GEE_LIBRARY_DIRS}
+- ${INDICATOR_LIBRARY_DIRS}
+ ${INDICATOR3_LIBRARY_DIRS}
+ ${XML_LIBRARY_DIRS}
+ ${XTST_LIBRARY_DIRS}
+@@ -134,7 +128,6 @@
+ ${GTK3_INCLUDE_DIRS}
+ ${CAIRO_INCLUDE_DIRS}
+ ${GEE_INCLUDE_DIRS}
+- ${INDICATOR_INCLUDE_DIRS}
+ ${INDICATOR3_INCLUDE_DIRS}
+ ${XML_INCLUDE_DIRS}
+ ${XTST_INCLUDE_DIRS}
+@@ -166,12 +159,8 @@
+ libarchive
+ )
+
+-if (${INDICATOR_FOUND})
+- LIST(APPEND VALA_PKGS appindicator-0.1)
+-endif (${INDICATOR_FOUND})
+-
+ if (${INDICATOR3_FOUND})
+- LIST(APPEND VALA_PKGS appindicator3-0.1)
++ LIST(APPEND VALA_PKGS ayatana-appindicator3-0.1)
+ endif (${INDICATOR3_FOUND})
+
+ if (${GMENU3_FOUND})
+@@ -210,7 +199,6 @@
+ message( " GTK3_LIBRARIES = ${GTK3_LIBRARIES}" )
+ message( " CAIRO_LIBRARIES = ${CAIRO_LIBRARIES}" )
+ message( " GEE_LIBRARIES = ${GEE_LIBRARIES}" )
+-message( " INDICATOR_LIBRARIES = ${INDICATOR_LIBRARIES}" )
+ message( " INDICATOR3_LIBRARIES = ${INDICATOR3_LIBRARIES}" )
+ message( " XML_LIBRARIES = ${XML_LIBRARIES}" )
+ message( " XTST_LIBRARIES = ${XTST_LIBRARIES}" )