summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-27 14:20:17 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-12-27 14:20:17 +0100
commit26501b6781cc3a4c92c400a08fd9f2cabaded161 (patch)
tree757445180e2e4a5f1ad5fe8ab4cd35034f26be2f /debian/rules
parenta49b4aa0d641155be104423e05028851491313e0 (diff)
Fix enablement of usb interface; Drop both dh-autoreconf/dh-systemd
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index d8256c4..5bb138a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,14 +13,15 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
# Platform-specific features
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-ifneq ($(DEB_HOST_ARCH_OS),linux)
+ifeq ($(DEB_HOST_ARCH_OS),linux)
# USB implementation is Linux-specific
+ extra_config_opts += --enable-intf-usb
+else
extra_config_opts += --disable-intf-usb
endif
-
%:
- dh $@ --with systemd,autoreconf
+ dh $@
override_dh_auto_install:
dh_auto_install