summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2014-07-23 15:03:00 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2014-07-23 15:03:00 +0200
commitb32d92e890caac903491116e9d817aa780c0323b (patch)
tree5a135c37eaa9ac94772819a28ce5beedd18e5c4a /debian/rules
parentc3445516ecd58e97de483cf4b7fafcc1104890d7 (diff)
Imported Upstream version 1.8.14upstream/1.8.14
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules68
1 files changed, 37 insertions, 31 deletions
diff --git a/debian/rules b/debian/rules
index 255653e..96a6920 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,7 @@
#!/usr/bin/make -f
-include /usr/share/quilt/quilt.make
-
#export DH_VERBOSE=1
+export DH_COMPAT=4
export DH_OPTIONS
CFLAGS = -Wall -g
@@ -17,10 +16,11 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
endif
configure: configure-stamp
-configure-stamp: patch
+configure-stamp:
dh_testdir
- cp /usr/share/misc/config.sub config.sub
- cp /usr/share/misc/config.guess config.guess
+
+ ./bootstrap
+
./configure --prefix=/usr \
--with-kerneldir \
--mandir=/usr/share/man
@@ -31,27 +31,24 @@ build: build-arch build-indep
build-arch: build-arch-stamp
build-arch-stamp: configure-stamp
-
- # Add here commands to compile the arch part of the package.
+
+# Add here commands to compile the arch part of the package.
$(MAKE)
- touch build-arch-stamp
build-indep: build-indep-stamp
build-indep-stamp: configure-stamp
- touch build-indep-stamp
- # Add here commands to compile the indep part of the package.
- #$(MAKE) doc
+# Add here commands to compile the indep part of the package.
+#$(MAKE) doc
-clean: unpatch
+clean:
dh_testdir
dh_testroot
rm -f build-arch-stamp build-indep-stamp configure-stamp
- rm -f config.sub config.guess
-
- # Add here commands to clean up after the build process.
- if [ -f Makefile ]; then $(MAKE) distclean; fi
-
+
+# Add here commands to clean up after the build process.
+ -$(MAKE) distclean
+
dh_clean
install: install-arch #install-indep
@@ -61,26 +58,34 @@ install-indep:
dh_clean -k -i
dh_installdirs -i
- # Add here commands to install the indep part of the package into
- # debian/<package>-doc.
- #INSTALLDOC#
- # $(MAKE) install-doc DESTDIR=$(CURDIR)/debian/tmp/ipmitool-doc
- # dh_movefiles -i
+# Add here commands to install the indep part of the package into
+# debian/<package>-doc.
+#INSTALLDOC#
+# $(MAKE) install-doc DESTDIR=$(CURDIR)/debian/tmp/ipmitool-doc
+# dh_movefiles -i
install-arch:
dh_testdir
dh_testroot
dh_clean -k -a
dh_installdirs -a
-
- # Add here commands to install the arch part of the package into
- # debian/tmp.
+
+# Add here commands to install the arch part of the package into
+# debian/tmp.
$(MAKE) install DESTDIR=$(CURDIR)/debian/ipmitool
-
- # No need to have two copies of the license text/changelog in the package.
+
+ # No need to have two copies of the license text in the package.
$(RM) $(CURDIR)/debian/ipmitool/usr/share/doc/ipmitool/COPYING
- $(RM) $(CURDIR)/debian/ipmitool/usr/share/doc/ipmitool/ChangeLog
+ # Move upstream changelog to correct filename.
+ mv $(CURDIR)/debian/ipmitool/usr/share/doc/ipmitool/ChangeLog \
+ $(CURDIR)/debian/ipmitool/usr/share/doc/ipmitool/changelog
+
+ # Compress to avoid lintian warning. Not sure why dh_compress
+ # isn't fixing this.
+ gzip -9 $(CURDIR)/debian/ipmitool/usr/share/doc/ipmitool/changelog
+
+# dh_movefiles -a
# Must not depend on anything. This is to be called by
# binary-arch/binary-multi
# in another 'make' thread.
@@ -88,8 +93,8 @@ binary-common:
dh_testdir
dh_testroot
dh_installdocs
- dh_installchangelogs ChangeLog
- dh_installinit --name ipmievd --error-handler=ipmievd_initd_failed
+ dh_installchangelogs
+ dh_installinit --name ipmievd
dh_link
dh_strip
dh_compress
@@ -109,4 +114,5 @@ binary-arch: build-arch install-arch
$(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
binary: binary-arch #binary-indep
-.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install install-indep install-arch configure
+.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure
+