summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2016-04-13 03:14:54 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2016-04-13 03:14:54 +0200
commitb8872c3c0fcda7bc9824b1d84e910f1af664a492 (patch)
tree7ad8c458d4cb073d0329dcc6d4bec9f9384de416 /debian/rules
parente3b9981f94a8d1624938dc011764f95da40a8b49 (diff)
Use of USB only on Linux architectures
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 10 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 2b8f7e2..76c0336 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,15 @@ export DH_OPTIONS
#
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+# Platform-specific features
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+
+ifneq ($(DEB_HOST_ARCH_OS),linux)
+ # USB implementation is Linux-specific
+ extra_config_opts += --disable-intf-usb
+endif
+
+
%:
dh $@ --with systemd,autoreconf
@@ -31,4 +40,4 @@ override_dh_systemd_enable:
dh_systemd_enable --no-enable ipmievd.service
override_dh_auto_configure:
- dh_auto_configure -- --prefix=/usr --with-kerneldir --mandir=/usr/share/man
+ dh_auto_configure -- --prefix=/usr --with-kerneldir --mandir=/usr/share/man $(extra_config_opts)