summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMatthew Johnson <mjj29@adonis.trinhall.cam.ac.uk>2009-03-22 16:45:03 +0000
committerMatthew Johnson <mjj29@adonis.trinhall.cam.ac.uk>2009-03-22 16:45:03 +0000
commitc046fdc3b05cb15bc8e599dd9c8604a847c84707 (patch)
tree3c08a8c39f7b81166e096165e158547555d244e5 /debian/rules
parenta30edbecd81e8f5641c6be9397b2e93358b1d72d (diff)
switch to quilt
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 6 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index adbc323..255653e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+include /usr/share/quilt/quilt.make
+
#export DH_VERBOSE=1
export DH_OPTIONS
@@ -15,8 +17,10 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
endif
configure: configure-stamp
-configure-stamp: patch-stamp
+configure-stamp: patch
dh_testdir
+ cp /usr/share/misc/config.sub config.sub
+ cp /usr/share/misc/config.guess config.guess
./configure --prefix=/usr \
--with-kerneldir \
--mandir=/usr/share/man
@@ -43,6 +47,7 @@ clean: unpatch
dh_testdir
dh_testroot
rm -f build-arch-stamp build-indep-stamp configure-stamp
+ rm -f config.sub config.guess
# Add here commands to clean up after the build process.
if [ -f Makefile ]; then $(MAKE) distclean; fi
@@ -105,5 +110,3 @@ binary-arch: build-arch install-arch
binary: binary-arch #binary-indep
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install install-indep install-arch configure
-
-include /usr/share/dpatch/dpatch.make