summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-01-05 14:50:23 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-01-05 14:50:23 +0100
commitd0c79cda3b08717544a5f33b948cd8bdfcd462f2 (patch)
tree2e7d859a9f438be870992219d7da874d409e8ab4 /debian/rules
parentaf16369cd594e64abec0d662f0fdbfe487c212d5 (diff)
Remove load of kernel modules via init scripts
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index b2ed159..52a96a6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,7 +15,6 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
override_dh_auto_install:
dh_auto_install
- cp -f $(CURDIR)/debian/systemd/ipmitool.conf $(CURDIR)/debian/ipmitool/usr/lib/modules-load.d/ipmievd.conf
# No need to have two copies of the license text/changelog in the package.
$(RM) $(CURDIR)/debian/ipmitool/usr/share/doc/ipmitool/COPYING
$(RM) $(CURDIR)/debian/ipmitool/usr/share/doc/ipmitool/ChangeLog
@@ -23,5 +22,8 @@ override_dh_auto_install:
override_dh_installinit:
dh_installinit --name ipmievd --error-handler=ipmievd_initd_failed
+override_dh_systemd_enable:
+ dh_systemd_enable --no-enable ipmievd.service
+
override_dh_auto_configure:
dh_auto_configure -- --prefix=/usr --with-kerneldir --mandir=/usr/share/man