summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7493f0e..6b9d202 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(ipmiutil,3.1.6)
+AC_INIT(ipmiutil,3.1.7)
AC_CONFIG_SRCDIR(util/ipmiutil.c)
echo "ipmiutil version ${PACKAGE_VERSION}"
AC_CONFIG_HEADERS(config.h)
@@ -57,7 +57,7 @@ LIB_DIR="/usr/lib"
isredhat=0
init_scripts="scripts/ipmi_port.sh scripts/ipmiutil_evt scripts/ipmiutil_asy scripts/ipmiutil_wdt"
projdir=`pwd`
-SUBDIR_S="doc scripts lib util"
+SUBDIR_S="scripts lib util"
os=Linux
# ltmain.sh, config.sub, et al should have been created, but check to be sure.
@@ -171,7 +171,7 @@ AC_ARG_ENABLE([standalone],
LANPLUS_SAM="no"
LD_SAMX=""
CFLAGS="-O2"
- SUBDIR_S="doc scripts util"
+ SUBDIR_S="scripts util"
if test "x$cross_compiling" = "xyes"; then
# cross-compiling, so link with -static (e.g. Android ARM)
CROSS_LFLAGS="-static"
@@ -181,6 +181,15 @@ AC_ARG_ENABLE([standalone],
fi]
)
+AC_ARG_ENABLE([doc],
+ [ --enable-doc build with documentation [[default=yes]]],
+ [enable_doc=$enableval],
+ [enable_doc=yes]
+ )
+if test "x$enable_doc" = "xyes"; then
+ SUBDIR_S="$SUBDIR_S doc"
+fi
+
dnl build libipmiutil with sensor modules
AC_ARG_ENABLE([libsensors],
[ --enable-libsensors build libipmiutil with sensor modules [[default=no]]],