summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/patches/0100-out-of-bounds.patch61
-rw-r--r--debian/patches/0105-typo.patch13
-rw-r--r--debian/patches/0700-init.patch4
-rw-r--r--debian/patches/0705-crontab.patch4
-rw-r--r--debian/patches/0710-systemd.patch21
-rw-r--r--debian/patches/series2
7 files changed, 30 insertions, 88 deletions
diff --git a/debian/changelog b/debian/changelog
index db3801f..fe5e22c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+ipmiutil (3.1.9-1) unstable; urgency=medium
+
+ * New upstream release.
+ - Refresh patches:
+ + debian/patches/0700-init.patch
+ + debian/patches/0705-crontab.patch
+ + debian/patches/0105-typo.patch
+ * Remove old patches:
+ - debian/patches/0100-out-of-bounds.patch
+ - debian/patches/0710-systemd.patch
+
+ -- Jörg Frings-Fürst <debian@jff.email> Wed, 15 Mar 2023 21:26:30 +0100
+
ipmiutil (3.1.8-4) unstable; urgency=medium
* debian/patches/0705-crontab.patch: Fix typo (Closes: #1030120).
diff --git a/debian/patches/0100-out-of-bounds.patch b/debian/patches/0100-out-of-bounds.patch
deleted file mode 100644
index 19ba67b..0000000
--- a/debian/patches/0100-out-of-bounds.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-Description: prevent out-of-bounds
-Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
-Forwarded: https://sourceforge.net/p/ipmiutil/mailman/ipmiutil-developers/?viewmonth=201410
-Last-Update: 2014-10-29
----
-Index: trunk/util/ievents.c
-===================================================================
---- trunk.orig/util/ievents.c
-+++ trunk/util/ievents.c
-@@ -193,10 +193,10 @@ static const char *sensor_types[NSTYPES]
- /* 2Eh */ "ME" /* 0xDC == ME Node Manager */
- };
-
--#define NFWERRS 15
-+#define NFWERRS 14
- static struct { /* See Table 36-3, type 0Fh, offset 00h */
- int code; char *msg;
-- } fwerrs[NFWERRS] = {
-+ } fwerrs[NFWERRS + 1] = {
- { 0x00, "Unspecified"},
- { 0x01, "No system memory"},
- { 0x02, "No usable memory"},
-@@ -214,10 +214,10 @@ static struct { /* See Table 36-3, ty
- { 0x0E, "Reserved" }
- };
-
--#define NFWSTAT 27
-+#define NFWSTAT 26
- static struct { /* See Table 36-3, type 0Fh, offset 01h & 02h */
- int code; char *msg;
-- } fwstat[NFWSTAT] = {
-+ } fwstat[NFWSTAT + 1] = {
- { 0x00, "Unspecified"},
- { 0x01, "Memory init"},
- { 0x02, "Hard disk init"},
-Index: trunk/util/ifirewall.h
-===================================================================
---- trunk.orig/util/ifirewall.h
-+++ trunk/util/ifirewall.h
-@@ -82,7 +82,7 @@ struct lun_netfn_support {
- };
- struct lun_support {
- unsigned char support;
-- struct lun_netfn_support netfn[MAX_NETFN_PAIR];
-+ struct lun_netfn_support netfn[MAX_NETFN];
- };
- struct bmc_fn_support {
- struct lun_support lun[MAX_LUN];
-Index: trunk/util/iconfig.c
-===================================================================
---- trunk.orig/util/iconfig.c
-+++ trunk/util/iconfig.c
-@@ -1765,7 +1765,7 @@ int SerialIsOptional(int bparam)
- int optvals[9] = { 5, 9, 10, 11, 12, 13, 14, 20, 21 };
- int rv = 0;
- int i;
-- for (i = 0; i < sizeof(optvals); i++) {
-+ for (i = 0; i < (sizeof(optvals) / sizeof(int)); i++) {
- if (optvals[i] == bparam) { rv = 1; break; }
- }
- return(rv);
diff --git a/debian/patches/0105-typo.patch b/debian/patches/0105-typo.patch
index 70c9875..d3934a9 100644
--- a/debian/patches/0105-typo.patch
+++ b/debian/patches/0105-typo.patch
@@ -101,3 +101,16 @@ Index: trunk/util/ievents.c
/*07*/ "Bus Warn ", /* Bus Correctable Error */
/*08*/ "Bus Error", /* Bus Uncorrectable Error */
/*09*/ "Fatal NMI" };
+Index: trunk/util/oem_dell.c
+===================================================================
+--- trunk.orig/util/oem_dell.c
++++ trunk/util/oem_dell.c
+@@ -5642,7 +5642,7 @@ char * get_dell_evt_desc(uchar *sel_rec,
+ if(code == 0x10)
+ {
+ if((data1 & 0x0f) == 0x03) {
+- snprintf(desc,SIZE_OF_DESC,"All Even Logging Dissabled");
++ snprintf(desc,SIZE_OF_DESC,"All Even Logging Disabled");
+ *psev = SEV_INFO;
+ }
+ }
diff --git a/debian/patches/0700-init.patch b/debian/patches/0700-init.patch
index 506d4f4..36250a6 100644
--- a/debian/patches/0700-init.patch
+++ b/debian/patches/0700-init.patch
@@ -90,7 +90,7 @@ Index: trunk/scripts/ipmiutil_wdt
+. /lib/lsb/init-functions
+
name=ipmiutil_wdt
- prog="/usr/bin/ipmiutil wdt"
+ progn="/usr/bin/ipmiutil wdt"
wdtcron=/etc/cron.d/wdt
@@ -123,10 +125,13 @@ case "$1" in
restart)
@@ -216,7 +216,7 @@ Index: trunk/configure.ac
===================================================================
--- trunk.orig/configure.ac
+++ trunk/configure.ac
-@@ -421,11 +421,11 @@ else
+@@ -422,11 +422,11 @@ else
MD2_CFLAGS="-DSKIP_MD2"
init0=/etc/rc.d/init.d
fi
diff --git a/debian/patches/0705-crontab.patch b/debian/patches/0705-crontab.patch
index e8726c8..3099a15 100644
--- a/debian/patches/0705-crontab.patch
+++ b/debian/patches/0705-crontab.patch
@@ -12,9 +12,9 @@ Index: trunk/scripts/ipmiutil_wdt
if [ $RETVAL -eq 0 ]; then
# restart the watchdog every 60 seconds via /etc/cron.d
cat - <<%%% >$wdtcron
--* * * * * root $prog -r >/dev/null
+-* * * * * root $progn -r >/dev/null
+MAILTO=''
-+* * * * * root $prog -r >/dev/null 2>&1
++* * * * * root $progn -r >/dev/null 2>&1
%%%
# make crond re-read the /etc/cron.d
$restart_cron >>$wdtlog
diff --git a/debian/patches/0710-systemd.patch b/debian/patches/0710-systemd.patch
deleted file mode 100644
index 77ddc1b..0000000
--- a/debian/patches/0710-systemd.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Description: Escape not allowed characters at ExecStart
-Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
-Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=848861
-Forwarded: https://sourceforge.net/p/ipmiutil/mailman/ipmiutil-developers/thread/1482238056.9870.6.camel%40jff-webhosting.net/#msg35561807
-Last-Update: 2016-12-20
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
-Index: trunk/scripts/ipmi_port.service
-===================================================================
---- trunk.orig/scripts/ipmi_port.service
-+++ trunk/scripts/ipmi_port.service
-@@ -6,7 +6,8 @@ After=network.target
- Type=forking
- PIDFile=/run/ipmi_port.pid
- EnvironmentFile=/usr/share/ipmiutil/ipmiutil.env
--ExecStart=/usr/share/ipmiutil/ipmiutil.setup >/dev/null && /usr/sbin/ipmi_port -b || :
-+ExecStartPre=/usr/share/ipmiutil/ipmiutil.setup
-+ExecStart=-/usr/sbin/ipmi_port -b
-
- [Install]
- WantedBy=multi-user.target
diff --git a/debian/patches/series b/debian/patches/series
index 6fce8b9..c8614ec 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,6 +1,4 @@
-#0100-out-of-bounds.patch
0105-typo.patch
0700-init.patch
0600-typo-man.patch
0705-crontab.patch
-#0710-systemd.patch