summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2015-02-04 14:10:25 +0100
committerJörg Frings-Fürst <debian@jff-webhosting.net>2015-02-04 14:10:25 +0100
commitb92f3517ff627f7fe602004a9ba9d04755ff83fa (patch)
tree6e071669bddb4db32b9172826aa8d3301d41014e /debian/rules
parentbd82d030011cd8b9655e5ded6b6df9343b42a6bd (diff)
Initial import of libhx version 3.22-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0f62d7e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@ --with autoreconf
+
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-static
+
+override_dh_installchangelogs:
+# install custom changelog
+ dh_installchangelogs doc/changelog.txt