summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 519aa55..6c9d27e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@
PACKAGE = ${PACKAGE_NAME}
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = doc include src
+SUBDIRS = include src
pkgconfig_DATA = libHX.pc
@@ -15,8 +15,8 @@ packext = .tar.xz
.PHONY: tarball
tarball:
# do not use mkdir_p here.
- mkdir ${tmpdir};
- pushd ${top_srcdir} && git archive --prefix=${PACKAGE_NAME}-${PACKAGE_VERSION}/ HEAD | tar -C ${tmpdir} -x && popd;
- pushd ${tmpdir}/${PACKAGE_NAME}-${PACKAGE_VERSION} && ./autogen.sh && pushd doc/ && ./generate && popd && popd;
- tar --use=${packer} -C ${tmpdir} -cf ${PACKAGE_NAME}-${PACKAGE_VERSION}${packext} --owner=root --group=root ${PACKAGE_NAME}-${PACKAGE_VERSION}/;
- rm -Rf ${tmpdir};
+ mkdir ${tmpdir}
+ cd ${top_srcdir} && git archive --prefix=${PACKAGE_NAME}-${PACKAGE_VERSION}/ HEAD | tar -C ${tmpdir} -x
+ cd ${tmpdir}/${PACKAGE_NAME}-${PACKAGE_VERSION} && autoreconf -fi && rm -Rf autom4te.cache
+ tar --use=${packer} -C ${tmpdir} -cf ${PACKAGE_NAME}-${PACKAGE_VERSION}${packext} --owner=root --group=root ${PACKAGE_NAME}-${PACKAGE_VERSION}/
+ rm -Rf ${tmpdir}