summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..519aa55
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
+# -*- Makefile -*-
+
+PACKAGE = ${PACKAGE_NAME}
+ACLOCAL_AMFLAGS = -I m4
+SUBDIRS = doc include src
+
+pkgconfig_DATA = libHX.pc
+
+${pkgconfig_DATA}: ${top_builddir}/config.status
+
+tmpdir := $(shell mktemp -dtu)
+packer = xz
+packext = .tar.xz
+
+.PHONY: tarball
+tarball:
+# do not use mkdir_p here.
+ mkdir ${tmpdir};
+ pushd ${top_srcdir} && git archive --prefix=${PACKAGE_NAME}-${PACKAGE_VERSION}/ HEAD | tar -C ${tmpdir} -x && popd;
+ pushd ${tmpdir}/${PACKAGE_NAME}-${PACKAGE_VERSION} && ./autogen.sh && pushd doc/ && ./generate && popd && popd;
+ tar --use=${packer} -C ${tmpdir} -cf ${PACKAGE_NAME}-${PACKAGE_VERSION}${packext} --owner=root --group=root ${PACKAGE_NAME}-${PACKAGE_VERSION}/;
+ rm -Rf ${tmpdir};