summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 0f62d7e..4f4c5cc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,8 @@
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-/')
+
%:
dh $@ --with autoreconf
@@ -11,3 +13,8 @@ override_dh_auto_configure:
override_dh_installchangelogs:
# install custom changelog
dh_installchangelogs doc/changelog.txt
+
+override_dh_makeshlibs:
+ dh_makeshlibs
+ dpkg-gensymbols -v$(VERSION) -Pdebian/libhx28 -plibhx28
+ dpkg-gensymbols -v$(VERSION) -Pdebian/libhx-dev -plibhx-dev