summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am25
1 files changed, 13 insertions, 12 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 73a6bdb..c30b56c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -10,10 +10,10 @@ lib_LTLIBRARIES += libHX_rtcheck.la
endif
libHX_la_SOURCES = deque.c dl.c format.c io.c map.c \
- mc.c misc.c opt.c \
- rand.c string.c time.c
-libHX_la_LIBADD = ${libdl_LIBS} ${libpthread_LIBS} ${librt_LIBS}
-libHX_la_LDFLAGS = -no-undefined -version-info 32:0:0
+ mc.c misc.c opt.c proc.c \
+ rand.c socket.c string.c time.c
+libHX_la_LIBADD = ${libdl_LIBS} -lm ${libpthread_LIBS} ${librt_LIBS}
+libHX_la_LDFLAGS = -no-undefined -version-info 35:0:3
if WITH_GNU_LD
libHX_la_LDFLAGS += -Wl,--version-script=${srcdir}/libHX.map
endif
@@ -21,9 +21,7 @@ EXTRA_libHX_la_DEPENDENCIES = libHX.map
if MINGW32
libHX_la_SOURCES += ux-file.c ux-mmap.c
-endif
-if B_PROC
-libHX_la_SOURCES += proc.c
+libHX_la_LIBADD += -lws2_32
endif
libHX_rtcheck_la_SOURCES = rtcheck.c
@@ -35,17 +33,18 @@ endif
EXTRA_DIST = internal.h map_int.h libHX.map
-check_PROGRAMS = tc-compile tc-cast tc-deque tc-dir tc-format tc-link \
+check_PROGRAMS = tc-compile tc-cast tc-deque tc-dir tc-format tc-io \
tc-list tc-list2 tc-map tc-memmem tc-misc tc-netio \
tc-option tc-proc tc-rand tc-realpath \
- tc-shconfig tc-strchr2 tc-string tc-strquote tc-time
+ tc-shconfig tc-strchr2 tc-string tc-strquote \
+ tc-switchuser tc-time
TESTS = tc-strchr2 tc-strquote
tc_cast_CFLAGS = ${AM_CFLAGS} -std=gnu99
tc_cast_LDADD = libHX.la -lm
tc_compile_LDADD = libHX.la
tc_dir_LDADD = libHX.la
tc_format_LDADD = libHX.la
-tc_link_LDADD = libHX.la
+tc_io_LDADD = libHX.la
tc_list_LDADD = libHX.la
tc_list2_LDADD = libHX.la
tc_list2_CFLAGS = ${AM_CFLAGS} -O2 -fstrict-aliasing
@@ -61,22 +60,24 @@ tc_shconfig_LDADD = libHX.la
tc_strchr2_LDADD = libHX.la
tc_string_LDADD = libHX.la
tc_strquote_LDADD = libHX.la
+tc_switchuser_LDADD = libHX.la
tc_time_LDADD = libHX.la
if HAVE_CXX
-check_PROGRAMS += tx-compile tx-cast tx-deque tx-dir tx-list tx-list2 \
+check_PROGRAMS += tx-compile tx-cast tx-deque tx-dir \
+ tx-intdiff tx-list tx-list2 \
tx-misc tx-netio \
tx-option tx-proc tx-rand tx-strchr2 tx-string \
tx-strquote tx-time
TESTS += tx-strchr2 tx-strquote
tx_cast_SOURCES = tx-cast.cpp
-tx_cast_CXXFLAGS = ${AM_CXXFLAGS} -std=c++98
tx_cast_LDADD = libHX.la -lm
tx_compile_SOURCES = tx-compile.cpp
tx_compile_LDADD = libHX.la
tx_deque_SOURCES = tx-deque.cpp
tx_dir_SOURCES = tx-dir.cpp
tx_dir_LDADD = libHX.la
+tx_intdiff_SOURCES = tx-intdiff.cpp
tx_list_SOURCES = tx-list.cpp
tx_list_LDADD = libHX.la
tx_list2_SOURCES = tx-list2.cpp