summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c30b56c..921e6b7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,7 +13,7 @@ libHX_la_SOURCES = deque.c dl.c format.c io.c map.c \
mc.c misc.c opt.c proc.c \
rand.c socket.c string.c time.c
libHX_la_LIBADD = ${libdl_LIBS} -lm ${libpthread_LIBS} ${librt_LIBS}
-libHX_la_LDFLAGS = -no-undefined -version-info 35:0:3
+libHX_la_LDFLAGS = -no-undefined -version-info 36:0:4
if WITH_GNU_LD
libHX_la_LDFLAGS += -Wl,--version-script=${srcdir}/libHX.map
endif
@@ -36,9 +36,9 @@ EXTRA_DIST = internal.h map_int.h libHX.map
check_PROGRAMS = tc-compile tc-cast tc-deque tc-dir tc-format tc-io \
tc-list tc-list2 tc-map tc-memmem tc-misc tc-netio \
tc-option tc-proc tc-rand tc-realpath \
- tc-shconfig tc-strchr2 tc-string tc-strquote \
+ tc-shconfig tc-socket tc-strchr2 tc-string tc-strquote \
tc-switchuser tc-time
-TESTS = tc-strchr2 tc-strquote
+TESTS = tc-format tc-strchr2 tc-strquote
tc_cast_CFLAGS = ${AM_CFLAGS} -std=gnu99
tc_cast_LDADD = libHX.la -lm
tc_compile_LDADD = libHX.la
@@ -57,6 +57,7 @@ tc_proc_LDADD = libHX.la
tc_rand_LDADD = libHX.la
tc_realpath_LDADD = libHX.la
tc_shconfig_LDADD = libHX.la
+tc_socket_LDADD = libHX.la
tc_strchr2_LDADD = libHX.la
tc_string_LDADD = libHX.la
tc_strquote_LDADD = libHX.la