summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 3 insertions, 14 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ac68f74..676cd73 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,15 +5,11 @@ AM_CFLAGS = ${regular_CFLAGS}
AM_CXXFLAGS = ${regular_CXXFLAGS}
lib_LTLIBRARIES = libHX.la
-if HAVE_DLFCN_H
-lib_LTLIBRARIES += libHX_rtcheck.la
-endif
-
libHX_la_SOURCES = deque.c dl.c format.c io.c map.c \
mc.c misc.c opt.c proc.c \
rand.c socket.c string.c time.c
libHX_la_LIBADD = ${libdl_LIBS} -lm ${libpthread_LIBS} ${librt_LIBS} ${libsocket_LIBS}
-libHX_la_LDFLAGS = -no-undefined -version-info 38:0:6
+libHX_la_LDFLAGS = -no-undefined -version-info 39:0:7
if WITH_GNU_LD
libHX_la_LDFLAGS += -Wl,--version-script=${srcdir}/libHX.map
endif
@@ -24,21 +20,14 @@ libHX_la_SOURCES += ux-file.c ux-mmap.c
libHX_la_LIBADD += -lws2_32
endif
-libHX_rtcheck_la_SOURCES = rtcheck.c
-libHX_rtcheck_la_LIBADD = ${libdl_LIBS}
-libHX_rtcheck_la_LDFLAGS = -no-undefined -avoid-version -module
-if WITH_GNU_LD
-libHX_rtcheck_la_LDFLAGS += -Wl,--version-script=${srcdir}/libHX.map
-endif
-
-EXTRA_DIST = internal.h map_int.h libHX.map
+EXTRA_DIST = internal.h map_int.h libHX.map uxcompat.h analyze.sh
check_PROGRAMS = tc-compile tc-cast tc-deque tc-dir tc-format tc-io \
tc-list tc-list2 tc-map tc-memmem tc-misc tc-netio \
tc-option tc-proc tc-rand tc-realpath \
tc-shconfig tc-socket tc-strchr2 tc-string tc-strquote \
tc-switchuser tc-time
-TESTS = tc-format tc-strchr2 tc-strquote
+TESTS = tc-format tc-option tc-strchr2 tc-string tc-strquote
tc_cast_CFLAGS = ${AM_CFLAGS} -std=gnu99
tc_cast_LDADD = libHX.la -lm
tc_compile_LDADD = libHX.la