summaryrefslogtreecommitdiff
path: root/debian/patches/0001-hardening.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-hardening.patch')
-rw-r--r--debian/patches/0001-hardening.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/patches/0001-hardening.patch b/debian/patches/0001-hardening.patch
new file mode 100644
index 0000000..e3c77eb
--- /dev/null
+++ b/debian/patches/0001-hardening.patch
@@ -0,0 +1,20 @@
+Description: Fix hardening
+Author: Jörg Frings-Fürst <debian@jff.email>
+Last-Update: 2018-10-01
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: trunk/configure.ac
+===================================================================
+--- trunk.orig/configure.ac
++++ trunk/configure.ac
+@@ -73,8 +73,8 @@ int main()
+ return 0;
+ }
+ ]])],[blb_cv_glib_sane=yes],[blb_cv_glib_sane=no],[blb_cv_glib_sane=yes])])
+-CPPFLAGS=$old_CPPFLAGS
+-LDFLAGS=$old_LDFLAGS
++CPPFLAGS="$old_CPPFLAGS -fPIE"
++LDFLAGS="$old_LDFLAGS -fPIE -pie"
+
+ if test "x$blb_cv_glib_sane" = "xno"; then
+ AC_MSG_ERROR([Glib headers inconsistent with current compiler setting. You might be using 32 bit Glib with a 64 bit compiler, check PKG_CONFIG_PATH])