summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules49
1 files changed, 0 insertions, 49 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index c4ddaa7..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,49 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-
-export DH_OPTIONS += -O-Bbuild-tree
-
-UPSTREAM_VERSION=$(shell dpkg-parsechangelog | sed -n '/\(Version:\)/{s/^Version:[[:space:]]\+\([0-9]\+:\)\?\(.*\)/\2/p}' | rev | cut -d- -f 2- | rev)
-
-%:
- dh $@ --with autoreconf
-
-##
-# Arch dependent overrides
-##
-override_dh_autoreconf-arch:
- dh_autoreconf
-
-override_dh_auto_configure-arch:
- dh_auto_configure -- --enable-shared
-
-override_dh_auto_build-arch:
- dh_auto_build -- V=1
-
-override_dh_auto_test-arch:
- dh_auto_test -- V=1
-
-##
-# Arch independent overrides
-##
-override_dh_autoreconf-indep override_dh_auto_configure-indep: ;
-override_dh_auto_test-indep override_dh_auto_install-indep: ;
-override_dh_auto_build-indep:
- install -d build-tree/docs/html
- cd build-tree && sed -e "s,@VERSION@,${UPSTREAM_VERSION},g" \
- -e "s,@top_srcdir@,../,g" \
- <../Doxyfile.in >Doxyfile
- cd build-tree && doxygen
-
-##
-# Overrides common to both
-##
-override_dh_installdocs:
- dh_installdocs --link-doc=libmongo-client0
-
-override_dh_compress:
- dh_compress -Xusr/share/doc/libmongo-client0/examples/ \
- -Xusr/share/doc/libmongo-client0/html/
-
-override_dh_strip:
- dh_strip --dbg-package=libmongo-client0-dbg