summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 3 insertions, 16 deletions
diff --git a/debian/rules b/debian/rules
index 388b48f..9a96c74 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,20 +6,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DH_OPTIONS += -O-Bbuild-tree
-UPSTREAM_VERSION=$(shell dpkg-parsechangelog | sed -n '/\(Version:\)/{s/^Version:[[:space:]]\+\([0-9]\+:\)\?\(.*\)/\2/p}' | rev | cut -d- -f 2- | rev)
-
-LDFLAGS += -fPIE -pie -Wl,-z,relro -Wl,-z,now -fPIC
-CPPFLAGS += -D_FORTIFY_SOURCE=2 -fPIE -pie -Wl,-z,relro -Wl,-z,now
-CFLAGS += -D_FORTIFY_SOURCE=2 -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -fPIE -pie -Wl,-z,relro -Wl,-z,now
-export CPPFLAGS
-export CFLAGS
-export LDFLAGS
-
-#
-# Test for gcc-5 support
-#
-#export CC=gcc-5
-#export CXX=g++-5
+include /usr/share/dpkg/pkg-info.mk
%:
dh $@
@@ -46,7 +33,7 @@ override_dh_autoreconf-indep override_dh_auto_configure-indep: ;
override_dh_auto_test-indep override_dh_auto_install-indep: ;
override_dh_auto_build-indep:
install -d build-tree/docs/html
- cd build-tree && sed -e "s,@VERSION@,${UPSTREAM_VERSION},g" \
+ cd build-tree && sed -e "s,@VERSION@,$(DEB_VERSION_UPSTREAM),g" \
-e "s,@top_srcdir@,../,g" \
<../Doxyfile.in >Doxyfile
cd build-tree && doxygen
@@ -61,4 +48,4 @@ override_dh_compress:
override_dh_makeshlibs:
dh_makeshlibs
- dpkg-gensymbols -v$(UPSTREAM_VERSION) -plibmongo-client0
+ dpkg-gensymbols -v$(DEB_VERSION_UPSTREAM) -plibmongo-client0