summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff.email>2021-04-26 17:40:21 +0200
committerJörg Frings-Fürst <debian@jff.email>2021-04-26 17:40:21 +0200
commitd3a83c35311ec631a46b59b66c38ef8d3a2a629a (patch)
tree28fc4dd524fa29f712020b61e565ab47b1fefd8e /test/Makefile.am
parent77a04959299aa252579a98655e626d1b8f5f9f34 (diff)
parent98f7065a3f7b386564840bb5b24b94f9335b2e97 (diff)
Update upstream source from tag 'upstream/6.9.7.1'
Update to upstream version '6.9.7.1' with Debian dir c2c92e088b7e91033d7f5bee51ac7827148eaf4b
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index f12eebe..36f8dbe 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,14 +1,14 @@
## Makefile.am for Oniguruma
lib_onig = ../src/libonig.la
-AM_LDFLAGS = -L$(prefix)/lib
+AM_LDFLAGS = -L$(libdir)
AM_CFLAGS = -Wall -Wno-invalid-source-encoding
AM_CPPFLAGS = -I$(top_srcdir)/src
if ENABLE_POSIX_API
-TESTS = test_utf8 test_syntax testc testp testcu test_regset test_back
+TESTS = test_utf8 test_syntax test_options testc testp testcu test_regset test_back
else
-TESTS = test_utf8 test_syntax testc testcu test_regset test_back
+TESTS = test_utf8 test_syntax test_options testc testcu test_regset test_back
endif
check_PROGRAMS = $(TESTS)
@@ -18,6 +18,8 @@ test: test_uchar $(TESTS)
@./test_utf8 | grep RESULT
@echo "[Oniguruma API, SYNTAX check]"
@./test_syntax | grep RESULT
+ @echo "[Oniguruma API, Options check]"
+ @./test_options | grep RESULT
@echo "[Oniguruma API, EUC-JP check]"
@./testc | grep RESULT
if ENABLE_POSIX_API
@@ -43,6 +45,9 @@ test_utf8_LDADD = $(lib_onig)
test_syntax_SOURCES = test_syntax.c
test_syntax_LDADD = $(lib_onig)
+test_options_SOURCES = test_options.c
+test_options_LDADD = $(lib_onig)
+
testc_SOURCES = testc.c
testc_LDADD = $(lib_onig)
@@ -62,6 +67,7 @@ test_back_LDADD = $(lib_onig)
gcov:
make CFLAGS="--coverage" test_utf8
make CFLAGS="--coverage" test_syntax
+ make CFLAGS="--coverage" test_options
make CFLAGS="--coverage" testc
if ENABLE_POSIX_API
make CFLAGS="--coverage" testp