summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 36f8dbe..94739a2 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -13,7 +13,7 @@ endif
check_PROGRAMS = $(TESTS)
-test: test_uchar $(TESTS)
+test: test_uchar test_regex_t $(TESTS)
@echo "[Oniguruma API, UTF-8 check]"
@./test_utf8 | grep RESULT
@echo "[Oniguruma API, SYNTAX check]"
@@ -39,6 +39,12 @@ test_uchar:
@grep "\(^\|[^g]\)UChar" $(top_srcdir)/src/oniguruma.h
@echo ""
+test_regex_t:
+ @echo "[regex_t in oniguruma.h check]"
+ @grep "\(^\|[^[:alnum:]]\)regex_t" $(top_srcdir)/src/oniguruma.h
+ @echo ""
+
+
test_utf8_SOURCES = test_utf8.c
test_utf8_LDADD = $(lib_onig)