summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index fe48403..2930e7f 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -5,11 +5,13 @@ AM_LDFLAGS = -L$(prefix)/lib
AM_CFLAGS =
AM_CPPFLAGS = -I../src -I$(includedir)
-TESTS = testc testp testcu
+TESTS = test_utf8 testc testp testcu
-check_PROGRAMS = testc testp testcu
+check_PROGRAMS = test_utf8 testc testp testcu
-test: testc testp testcu
+test: test_utf8 testc testp testcu
+ @echo "[Oniguruma API, UTF-8 check]"
+ @./test_utf8 | grep RESULT
@echo "[Oniguruma API, ASCII/EUC-JP check]"
@./testc | grep RESULT
@echo "[POSIX API, ASCII/EUC-JP check]"
@@ -17,6 +19,9 @@ test: testc testp testcu
@echo "[Oniguruma API, UTF-16 check]"
@./testcu | grep RESULT
+test_utf8_SOURCES = test_utf8.c
+test_utf8_LDADD = $(lib_onig)
+
testc_SOURCES = testc.c
testc_LDADD = $(lib_onig)