summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndreas Rottmann <a.rottmann@gmx.at>2009-09-14 12:32:44 +0200
committerAndreas Rottmann <a.rottmann@gmx.at>2009-09-14 12:32:44 +0200
commitfa095a4504cbe668e4244547e2c141597bea4ecf (patch)
tree06135820a286ffec47804e75fbf8a147e92acd2e /Makefile.am
Imported Upstream version 0.9.1upstream/0.9.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..91c0bf3
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,41 @@
+## Makefile for the toplevel directory of GNU libunistring.
+## Copyright (C) 2009 Free Software Foundation, Inc.
+##
+## This program is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 3 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
+ACLOCAL = build-aux/fixaclocal @ACLOCAL@
+ACLOCAL_AMFLAGS = -I m4 -I gnulib-m4
+
+SUBDIRS = doc gnulib-local lib tests
+
+EXTRA_DIST = \
+ version.sh BUGS DEPENDENCIES HACKING autogen.sh \
+ build-aux/fixaclocal build-aux/texi2html build-aux/run-test
+
+
+# Allow users to use "gnulib-tool --update".
+EXTRA_DIST += gnulib-m4/gnulib-cache.m4
+
+
+# Cygwin support.
+
+EXTRA_DIST += woe32dll/export.h
+
+
+# Woe32 support.
+
+EXTRA_DIST += README.woe32 build-aux/windres-options