summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Frings-Fürst <debian@jff-webhosting.net>2017-03-27 21:45:10 +0200
committerJörg Frings-Fürst <debian@jff-webhosting.net>2017-03-27 21:45:10 +0200
commitca97d03abffc90c248d14b7f01f843de52b0d5d3 (patch)
treef86f8b716b0e08fcfecc3ec1853cc1e99416398b /debian/rules
parentdb6f1f397f45ccd3c11d16352ed46a9c1eae3442 (diff)
new upstream release
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e7fbeec
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+#export DH_VERBOSE=1
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/buildvars.mk
+include /usr/share/cdbs/1/rules/autoreconf.mk
+
+ifneq ($(findstring $(DEB_BUILD_ARCH), mips mipsel),)
+ CFLAGS += -mplt
+endif
+
+DEB_CONFIGURE_EXTRA_FLAGS := --disable-Werror \
+ --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH)
+DEB_DH_INSTALL_ARGS := --sourcedir=$(DEB_DESTDIR)
+
+DEB_MAKE_CHECK_TARGET = check