summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorStephen Kitt <skitt@debian.org>2016-05-27 10:11:04 +0200
committerManuel A. Fernandez Montecelo <manuel.montezelo@gmail.com>2016-05-27 14:28:33 +0100
commit752fd7247bc223bcea35bd89cf56d1c08ead9ba6 (patch)
treeb4a428f847a963738faaf24c8eff070fdb03a3a5 /debian
parent9f7d4fa477ff2a51d7c932b13d57ac22dc033105 (diff)
parenta9a31b1de5776a3b08a82101a4fa711294f0dd1d (diff)
Imported Debian patch 0.9.6+really0.9.3-0.1debian/0.9.6+really0.9.3-0.1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/copyright2
-rw-r--r--debian/libunistring0.triggers1
-rw-r--r--debian/patches/float-endian-detection.patch20
4 files changed, 19 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index 0aef394..cac6927 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,12 @@
-libunistring (0.9.6-1.1) unstable; urgency=medium
+libunistring (0.9.6+really0.9.3-0.1) unstable; urgency=medium
* Non-maintainer upload.
- * New upstream release. (Closes: #804064)
- * debian/patches: refresh for new upstream version
- * debian/copyright: fix typo in path
+ * Re-upload 0.9.3-5.4 to revert the soname bump in 0.9.6-1.1. (Closes:
+ #825471.)
+ * Drop the explicit ldconfig triggers, debhelper handles this on its
+ own.
- -- Manuel A. Fernandez Montecelo <mafm@debian.org> Thu, 26 May 2016 21:06:56 +0100
+ -- Stephen Kitt <skitt@debian.org> Fri, 27 May 2016 10:11:04 +0200
libunistring (0.9.3-5.3) unstable; urgency=medium
diff --git a/debian/copyright b/debian/copyright
index 8ca9a37..276411a 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -11,7 +11,7 @@ Files: doc/*
Copyright: 2001-2009, Free Software Foundation, Inc.
License: GPL-3+ or GFDL-1.2+
-Files: tests/* woe32dll/* autogen.sh
+Files: test/* woe32dll/* autogen.sh
Copyright: 1990-2009, Free Software Foundation, Inc.
License: GPL-3+
diff --git a/debian/libunistring0.triggers b/debian/libunistring0.triggers
deleted file mode 100644
index dd86603..0000000
--- a/debian/libunistring0.triggers
+++ /dev/null
@@ -1 +0,0 @@
-activate-noawait ldconfig
diff --git a/debian/patches/float-endian-detection.patch b/debian/patches/float-endian-detection.patch
index d094516..66bed0d 100644
--- a/debian/patches/float-endian-detection.patch
+++ b/debian/patches/float-endian-detection.patch
@@ -5,11 +5,13 @@ Author: Colin Watson <cjwatson@ubuntu.com>
Forwarded: no
Last-Update: 2013-12-18
+Index: b/tests/test-isnanl.h
+===================================================================
--- a/tests/test-isnanl.h
+++ b/tests/test-isnanl.h
-@@ -24,6 +24,12 @@
- #include "nan.h"
- #include "macros.h"
+@@ -38,6 +38,12 @@
+ long double minus_zero = -0.0L;
+ #endif
+#ifdef __FLOAT_WORD_ORDER__
+# define FLOAT_BIG_ENDIAN (__FLOAT_WORD_ORDER__ != __ORDER_LITTLE_ENDIAN__)
@@ -20,7 +22,7 @@ Last-Update: 2013-12-18
int
main ()
{
-@@ -65,10 +71,10 @@
+@@ -70,10 +76,10 @@
# if LDBL_EXPBIT0_BIT > 0
m.word[LDBL_EXPBIT0_WORD] ^= (unsigned int) 1 << (LDBL_EXPBIT0_BIT - 1);
# else
@@ -33,11 +35,13 @@ Last-Update: 2013-12-18
|= (unsigned int) 1 << LDBL_EXPBIT0_BIT;
ASSERT (isnanl (m.value));
}
+Index: b/tests/test-signbit.c
+===================================================================
--- a/tests/test-signbit.c
+++ b/tests/test-signbit.c
-@@ -36,6 +36,12 @@
- double zerod = 0.0;
- long double zerol = 0.0L;
+@@ -56,6 +56,12 @@
+ long double minus_zerol = -0.0L;
+ #endif
+#ifdef __FLOAT_WORD_ORDER__
+# define FLOAT_BIG_ENDIAN (__FLOAT_WORD_ORDER__ != __ORDER_LITTLE_ENDIAN__)
@@ -48,7 +52,7 @@ Last-Update: 2013-12-18
static void
test_signbitf ()
{
-@@ -166,10 +172,10 @@
+@@ -176,10 +182,10 @@
# if LDBL_EXPBIT0_BIT > 0
m.word[LDBL_EXPBIT0_WORD] ^= (unsigned int) 1 << (LDBL_EXPBIT0_BIT - 1);
# else