summaryrefslogtreecommitdiff
path: root/debian/patches/0700-multiarch-libc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0700-multiarch-libc.patch')
-rw-r--r--debian/patches/0700-multiarch-libc.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/patches/0700-multiarch-libc.patch b/debian/patches/0700-multiarch-libc.patch
index a732d42..1686bcb 100644
--- a/debian/patches/0700-multiarch-libc.patch
+++ b/debian/patches/0700-multiarch-libc.patch
@@ -5,14 +5,14 @@ Index: trunk/lib/Makefile.am
===================================================================
--- trunk.orig/lib/Makefile.am
+++ trunk/lib/Makefile.am
-@@ -100,28 +100,13 @@ unistring/stdint.h : $(STDINT_H) stdint.
+@@ -101,30 +101,15 @@ unistring/stdint.h : $(STDINT_H) stdint.
echo '#if __GLIBC__ >= 2'; \
echo '#include <stdint.h>'; \
echo '#else'; \
- if test -f /usr/include/stdint.h; then \
- HAVE_STDINT_H='1'; \
- else \
-- HAVE_STDINT_H='defined __MINGW32__ || defined __HAIKU__'; \
+- HAVE_STDINT_H='defined __MINGW32__ || defined __HAIKU__ || ((__GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 5)) && !defined __NetBSD__)'; \
- fi; \
- if test -f /usr/include/inttypes.h; then \
- HAVE_INTTYPES_H='1'; \
@@ -24,6 +24,8 @@ Index: trunk/lib/Makefile.am
- else \
- HAVE_SYS_INTTYPES_H='0'; \
- fi; \
+ sed_escape_ampersands='s/&/\\&/g'; \
+ HAVE_STDINT_H=`echo "$$HAVE_STDINT_H" | sed -e "$$sed_escape_ampersands"`; \
- sed -e 's/@''HAVE_STDINT_H''@/'"$$HAVE_STDINT_H"'/g' \
+ sed -e 's/@''HAVE_STDINT_H''@/$(or @HAVE_STDINT_H@,0)/g' \
-e 's|@''INCLUDE_NEXT''@|include|g' \