summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5a0855a..b34aa21 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,8 @@
# hardening
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+include /usr/share/dpkg/default.mk
+
ifneq ($(findstring $(DEB_BUILD_ARCH), mips mipsel),)
CFLAGS += -mplt
endif
@@ -22,4 +24,4 @@ VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-
override_dh_makeshlibs:
dh_makeshlibs
- dpkg-gensymbols -v$(VERSION) -plibunistring5
+ dpkg-gensymbols -v$(DEB_VERSION_UPSTREAM) -plibunistring5