summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 2363e67..e03ce16 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,5 +20,11 @@ DEB_DH_INSTALL_ARGS := --sourcedir=$(DEB_DESTDIR)
DEB_MAKE_CHECK_TARGET = check
+VERSION = $(shell head -n1 debian/changelog | sed -e 's/.*(//;s/-.*).*//;s/\+/\-/')
+
%:
dh $@
+
+override_dh_makeshlibs:
+ dh_makeshlibs
+ dpkg-gensymbols -v$(VERSION) -plibunistring2