summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 2c8da9d..ffbfae2 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,5 +1,5 @@
## Makefile for the lib subdirectory of GNU libunistring.
-## Copyright (C) 2009 Free Software Foundation, Inc.
+## Copyright (C) 2009-2010 Free Software Foundation, Inc.
##
## This program is free software: you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
@@ -155,6 +155,20 @@ CLEANFILES += unistring/iconveh.h
# unistring/version.h is public.
nobase_nodist_include_HEADERS += unistring/version.h
+# unistring/cdefs.h is not public, but is included by other header files.
+nobase_nodist_include_HEADERS += unistring/cdefs.h
+unistring/cdefs.h : unistring/cdefs.in.h
+ @MKDIR_P@ unistring
+ rm -f $@-t $@
+ sed -e '/definition of _GL_UNUSED_PARAMETER/r $(UNUSED_PARAMETER_H)' \
+ < $(srcdir)/unistring/cdefs.in.h \
+ > $@-t
+ mv $@-t $@
+BUILT_SOURCES += unistring/cdefs.h
+MOSTLYCLEANFILES += unistring/cdefs.h-t
+CLEANFILES += unistring/cdefs.h
+EXTRA_DIST += unistring/cdefs.in.h
+
# unistring/woe32dll.h is not public, but is included by other header files.
nobase_nodist_include_HEADERS += unistring/woe32dll.h
@@ -288,7 +302,7 @@ AM_CPPFLAGS += -DDEPENDS_ON_LIBICONV=1
# Libtool's library version information for libunistring.
# See the libtool documentation, section "Library interface versions".
LTV_CURRENT=1
-LTV_REVISION=0
+LTV_REVISION=2
LTV_AGE=1
# How to build libunistring.la.