summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAlberto Gonzalez Iniesta <agi@inittab.org>2013-06-20 13:29:18 +0200
committerAlberto Gonzalez Iniesta <agi@inittab.org>2013-06-20 13:29:18 +0200
commitb9780e6608daf26a31979204189ce7721f312b32 (patch)
tree7da31ed20d5d1832b7e6429ff68a33f8763ff00d /debian/rules
parent089e87c0c39240d5d82126cbf366bd621cfae6d0 (diff)
Use iproute2 in linux
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 975881e..902b52b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,9 +2,9 @@
ifeq ($(DEB_HOST_ARCH_OS), kfreebsd)
# Avoid the /sbin/route wrapper which doesn't provide FreeBSD CLI as expected
-ROUTE_PATH := /lib/freebsd/route
+ROUTE_ARGS := --with-route-path=/lib/freebsd/route
else
-ROUTE_PATH := /sbin/route
+ROUTE_ARGS := --with-route-path=/sbin/route --with-iproute-path=/sbin/ip --enable-iproute2
endif
#export DH_VERBOSE=1
@@ -14,7 +14,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
dh $@
override_dh_auto_configure:
- dh_auto_configure -- $(shell dpkg-buildflags --export=configure) --enable-password-save --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --with-ifconfig-path=/sbin/ifconfig --with-route-path=$(ROUTE_PATH) --with-plugindir=\$${prefix}/lib/openvpn --includedir=\$${prefix}/include/openvpn --enable-pkcs11
+ dh_auto_configure -- $(shell dpkg-buildflags --export=configure) --enable-password-save --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --with-ifconfig-path=/sbin/ifconfig $(ROUTE_ARGS) --with-plugindir=\$${prefix}/lib/openvpn --includedir=\$${prefix}/include/openvpn --enable-pkcs11
override_dh_auto_build: