summaryrefslogtreecommitdiff
path: root/vendor/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/Makefile.am')
-rw-r--r--vendor/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/vendor/Makefile.am b/vendor/Makefile.am
index 674784a..46072c3 100644
--- a/vendor/Makefile.am
+++ b/vendor/Makefile.am
@@ -1,18 +1,18 @@
-# needs an absolute path bc. of the cmake invocation
-cmockasrc = "@VENDOR_SRC_ROOT@/cmocka"
-cmockabuild = "@VENDOR_BUILD_ROOT@/cmocka"
-cmockainstall = "@VENDOR_DIST_ROOT@"
+cmockasrc = $(srcdir)/cmocka
+# Not just '$(builddir)/cmocka', because cmocka requires an out-of-source build
+cmockabuild = $(builddir)/cmocka_build
+cmockadist = $(builddir)/dist
MAINTAINERCLEANFILES = \
$(srcdir)/Makefile.in \
"$(cmockabuild)" \
- "$(cmockainstall)" \
- "@VENDOR_BUILD_ROOT@"
+ "$(cmockadist)"
libcmocka:
if CMOCKA_INITIALIZED
- mkdir -p $(cmockabuild) $(cmockainstall)
- (cd $(cmockabuild) && cmake -DCMAKE_INSTALL_PREFIX=$(cmockainstall) $(cmockasrc) && make && make install)
+ mkdir -p $(cmockabuild) $(cmockadist)
+ ## Compensate for the cd in the paths
+ (cd $(cmockabuild) && cmake -DCMAKE_INSTALL_PREFIX=../$(cmockadist) ../$(cmockasrc) && make && make install)
endif
check: libcmocka